Chevy Avalanche Fan Club of North America Logo
Please login or register.

Login with username, password and session length
Advanced search  

News:

Keep CAFCNA Alive! Become a Supporting Member Today!

Pages: [1]   Go Down

Author Topic: HEATER FAN SWITCH NOT WORKING.......  (Read 16151 times)

0 Members and 1 Guest are viewing this topic.

GRUMPE

  • CAFCNA 2011 Supporting Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 1,957
HEATER FAN SWITCH NOT WORKING.......
« on: 01/21/06 09:12 PM »

 :help: I have an 03 4x4 cladded ave with 40,000 on it and I noticed about a week ago that the switch for the  fan does not work on speeds 1,2 and 3   :8:but are full blast on speeds 4 and 5. ???

Doese anyone know what may be the problem or a fix for this?

I thought about pulling that thing out to see if I can open it up to see if something is correted or not.  I would understand if none of the speeds worked and maybe it was the switch but why would some work and some not.

I have no clue with electronics so please explain to me like it would be written for  "Dummys for Electronics". :E:

Thanks in advance for any help....

RON
Logged
2004, 2 tone color kit*24" Wheels with 305 tires*Valancia Body Kit with Escalade rear kit** For All MY Mods of my old 03, LOOK HERE:]MY GARAGE

GRUMPE

  • CAFCNA 2011 Supporting Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 1,957
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #1 on: 01/22/06 09:06 AM »

 :help:

RON
Logged
2004, 2 tone color kit*24" Wheels with 305 tires*Valancia Body Kit with Escalade rear kit** For All MY Mods of my old 03, LOOK HERE:]MY GARAGE

SpottyJ

  • CAFCNA Global Moderator
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 2,952
  • This is SpottyJ
    • My Album
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #2 on: 01/23/06 07:54 AM »

Bump.

RON

You have manual climate controls and the fan selctor switch does not activate the fan/blower until position 4 or above - confirm?

I have searched the TSBs and don't have a TSB on that issue. 

I have auto climate control so I don't know how your setup operates. 

I will search the manuals for switch replacement instructions.

Regards,

SpottyJ
Logged
03' Z-71:  Drk Grn Met: Drv Conv Pckg, XM, OnStar, Sunroof, 10-way Heat Lthr Seats, Bose, Assist Steps, GND Effects Pckg, Roof Rack, Trlr Pckg, MODS: Maglite, Hardwire RADAR, Wheel Well Plug, WeatherTech Bug Shield, Bowtie by "Carriles", Silverstars-Fog/DRL/Signals, Rod Mod Remote Tailgate Lock, Zaino, HIDs in Lows.

SpottyJ

  • CAFCNA Global Moderator
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 2,952
  • This is SpottyJ
    • My Album
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #3 on: 01/23/06 07:59 AM »

RON

Not being famliar with the manual HVAC controls - does your system have three knobs in row?  And what do those knobs operate. (Trying to figure which system you have from the disagrams in my service manual)
Logged
03' Z-71:  Drk Grn Met: Drv Conv Pckg, XM, OnStar, Sunroof, 10-way Heat Lthr Seats, Bose, Assist Steps, GND Effects Pckg, Roof Rack, Trlr Pckg, MODS: Maglite, Hardwire RADAR, Wheel Well Plug, WeatherTech Bug Shield, Bowtie by "Carriles", Silverstars-Fog/DRL/Signals, Rod Mod Remote Tailgate Lock, Zaino, HIDs in Lows.

GRUMPE

  • CAFCNA 2011 Supporting Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 1,957
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #4 on: 01/23/06 09:50 AM »

Bump.

RON

You have manual climate controls and the fan selctor switch does not activate the fan/blower until position 4 or above - confirm?


You are correct!!!!!

Thanks and I appreaciate it.....


I tried useing liquid tape but that did not seem to help at all  :kidding:

RON
Quote
Quote
Logged
2004, 2 tone color kit*24" Wheels with 305 tires*Valancia Body Kit with Escalade rear kit** For All MY Mods of my old 03, LOOK HERE:]MY GARAGE

GRUMPE

  • CAFCNA 2011 Supporting Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 1,957
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #5 on: 01/23/06 09:53 AM »

RON

Not being famliar with the manual HVAC controls - does your system have three knobs in row?  And what do those knobs operate. (Trying to figure which system you have from the disagrams in my service manual)

It has the round knob that controls the fan sppeds 0-5 then two slidder knobs that controll the temp.  Cold -hot.

RON
Logged
2004, 2 tone color kit*24" Wheels with 305 tires*Valancia Body Kit with Escalade rear kit** For All MY Mods of my old 03, LOOK HERE:]MY GARAGE

gdmunk

  • Full Member
  • ***
  • Offline Offline
  • Posts: 121
  • Changes for 2016
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #6 on: 01/23/06 04:29 PM »

I had the same problem, the fan switch control uses a resister pack which is under the dash on the right side by the heater motor.  I replace the resister pack and now have all the fan speeds again.  Sorry I can't find the part number but any dealer will know what you're talking about.

Gary
gdmunk
Logged
Gary D. Munkens

SpottyJ

  • CAFCNA Global Moderator
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 2,952
  • This is SpottyJ
    • My Album
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #7 on: 01/23/06 04:47 PM »


Blower Motor Operates on High Only or Repeat Blower Resistor Failure - kw GMT800 GMT805 GMT820 GMT830 AC heater heat front air manual HVAC electrical wire high inoperative speed #PIT3081 - (Jul 22, 2004)
Blower Motor Operates on High Only or Repeat Blower Resistor Failure


The following diagnosis might be helpful if the vehicle exhibits the symptom described in the PI.

Condition/Concern:

Customers may comment that the A/C blower only operates on high or repeat blower resistor failures. Cause is a mis-positioned harness from the blower motor assembly to the right I/P fuse block C4 causing harness rub through at right I/P metal support.

Recommendation/Instructions:
Repair wiring and reposition blower motor harness away from the right I/P support. You may also want to insulate the I/P support bracket with foam tape to prevent any future concerns. Refer to SI Document 885398 for further details on wiring schematics for this circuit.

Please follow this diagnosis process thoroughly and complete each step. If the condition exhibited is resolved without completing every step, the remaining steps do not need to be performed. If these steps do not resolve the condition, please contact GM TAC for further diagnostic assistance.

Models:
(03-05 Chevrolet All Full Size Trucks And Utilities) and (03-05 GMC All Full Size Trucks and Utilities)

Logged
03' Z-71:  Drk Grn Met: Drv Conv Pckg, XM, OnStar, Sunroof, 10-way Heat Lthr Seats, Bose, Assist Steps, GND Effects Pckg, Roof Rack, Trlr Pckg, MODS: Maglite, Hardwire RADAR, Wheel Well Plug, WeatherTech Bug Shield, Bowtie by "Carriles", Silverstars-Fog/DRL/Signals, Rod Mod Remote Tailgate Lock, Zaino, HIDs in Lows.

GRUMPE

  • CAFCNA 2011 Supporting Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 1,957
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #8 on: 01/24/06 12:31 AM »

Thanks,
gdmunk and SpottyJ.

I think I will try to remove the control and see if I can find the harness they were talking about to see if that works.  If not I want to take a trip to the dealer to see if they will do the Gatorback stuff to my cladden.. I am out of warrenty but they know I have the problem cause I had them do the armodillo last spring and that lasted for about two weeks.  I'll have them check my heater out also.

Thanks Again,
RON
Logged
2004, 2 tone color kit*24" Wheels with 305 tires*Valancia Body Kit with Escalade rear kit** For All MY Mods of my old 03, LOOK HERE:]MY GARAGE

GRUMPE

  • CAFCNA 2011 Supporting Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 1,957
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #9 on: 01/30/06 11:01 PM »

I had the same problem, the fan switch control uses a resister pack which is under the dash on the right side by the heater motor.  I replace the resister pack and now have all the fan speeds again.  Sorry I can't find the part number but any dealer will know what you're talking about.

Gary
gdmunk

How hard was the install.

I took the heater out this weekend to check the wire harness to see if it was rubbing up against anything like in spottyj post but everything seems O.K.

RON
Logged
2004, 2 tone color kit*24" Wheels with 305 tires*Valancia Body Kit with Escalade rear kit** For All MY Mods of my old 03, LOOK HERE:]MY GARAGE

GRUMPE

  • CAFCNA 2011 Supporting Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 1,957
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #10 on: 02/07/06 08:56 AM »

Dealer wanted $100 or more to replace the resister pack so I bought the part my self.

 Part # 89018596 Resistor 9.216   $19.20


The problem I have is I have no clue where the heater blower is and how to replace this resistor pack.

I sent an e-mail to gdmunk to see if he can give me some directions.

Any help would be greatly appreciated.

Thanks,
RON
Logged
2004, 2 tone color kit*24" Wheels with 305 tires*Valancia Body Kit with Escalade rear kit** For All MY Mods of my old 03, LOOK HERE:]MY GARAGE

GRUMPE

  • CAFCNA 2011 Supporting Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 1,957
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #11 on: 02/08/06 10:17 AM »

Well, I fixed it today.

Thanks gdmunk for the help.

The only problem I had was the plug in the back of the blower.  I could not get that out.  Fingers too big and could not see back there.  You would have thought they would put that plug in front so your able to work on it.  Go figure, that would have made it to easy. 

I ended up cutting the wires and spliceing them instead.  Didn't want to do that but oh well she works now.

I have all 5 speeds.

Thanks spottyj and gdmunk.

Help me save $80.

Shop rat was $75 per hour.  Boy am i in the wrong professing......

RON
Logged
2004, 2 tone color kit*24" Wheels with 305 tires*Valancia Body Kit with Escalade rear kit** For All MY Mods of my old 03, LOOK HERE:]MY GARAGE

bbrat

  • Full Member
  • ***
  • Offline Offline
  • Posts: 64
  • Sask Avy
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #12 on: 12/16/06 08:44 AM »

Hello I have the same problem.  I was wondering were the blower motor is and how to change the resistor motor?  Could you point me in the right direction?

Thanks
Logged
03' Z71 Cladded Dark Grey Metallic
Mods - Hypertech Max Energy Tuner, Msd Plug Wires, airaid intake mod, Trans cooler, full time amber drl's, mag lite mod, 3" body lift, 285/70/R17 Nitto Terra Grapplers on Helo Maxx 6 Wheels, pioneer in dash dvd player, all 4 on high, Sirus sat. radio, pioneer premier 12" shallow mount sub in custom split midgate

ItsStopher

  • CAFCNA Global Moderator
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 5,340
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #13 on: 12/16/06 09:30 AM »

Look here <click me> for more information, this was on a 2002 but the resistor is in the same place. double check the part number before you order.
Logged

bbrat

  • Full Member
  • ***
  • Offline Offline
  • Posts: 64
  • Sask Avy
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #14 on: 12/17/06 08:24 AM »

Thanks for the link should be a piece of cake........... hopefully :wave:
Logged
03' Z71 Cladded Dark Grey Metallic
Mods - Hypertech Max Energy Tuner, Msd Plug Wires, airaid intake mod, Trans cooler, full time amber drl's, mag lite mod, 3" body lift, 285/70/R17 Nitto Terra Grapplers on Helo Maxx 6 Wheels, pioneer in dash dvd player, all 4 on high, Sirus sat. radio, pioneer premier 12" shallow mount sub in custom split midgate

bbrat

  • Full Member
  • ***
  • Offline Offline
  • Posts: 64
  • Sask Avy
Re: HEATER FAN SWITCH NOT WORKING.......
« Reply #15 on: 12/18/06 09:18 AM »

Well I got the part($60 from dealer) today thanks to the info on this site, now I just need to takle the install.

Thanks
Logged
03' Z71 Cladded Dark Grey Metallic
Mods - Hypertech Max Energy Tuner, Msd Plug Wires, airaid intake mod, Trans cooler, full time amber drl's, mag lite mod, 3" body lift, 285/70/R17 Nitto Terra Grapplers on Helo Maxx 6 Wheels, pioneer in dash dvd player, all 4 on high, Sirus sat. radio, pioneer premier 12" shallow mount sub in custom split midgate
Pages: [1]   Go Up
 

Page created in 0.085 seconds with 25 queries.