Chevy Avalanche Fan Club Forum

Avalanche Owners Zone => Chevy Avalanche Audio/Video & Electronics => A/V: Amps, Subs & Speakers => Topic started by: dbros on 07/13/09 11:36 AM

Title: Bad BOSE Amp 2004
Post by: dbros on 07/13/09 11:36 AM
Left the sunroof open on my 2004 with Bose system, and of course it rained. I know only have one speaker functioning. Can I replace my amp, can I go after market, or do I need to go back to GM to get one?

Thanks,

Dennis
Title: Re: Bad BOSE Amp 2004
Post by: I CHNGE on 07/13/09 12:00 PM
Yes you can replace it and it does not have to be an OEM Bose from dealer...if you go aftermarket you'll need adapter/s

Here is a good place to find them...

http://www.pac-audio.com/
Title: Re: Bad BOSE Amp 2004
Post by: MS03 2500 on 07/13/09 12:34 PM
:welcome: to the club Dbros you must have had a lot of rain to get to the AMP it is buried in the console. Check in  the under hood fuse box for a fuse labelled AMP and see if the fuse in blown.
Title: Re: Bad BOSE Amp 2004
Post by: dbros on 07/14/09 08:38 AM
Thanks I will check the fuse. And oh ya - it was a lot of rain overnight, the type of rain that wakes you up in the middle of the night.

Probably stick with the factory setup, unless its cheaper going after market, not a big stereo buff and was pretty happy with the system, but I miss it!
Title: Re: Bad BOSE Amp 2004
Post by: bethg64 on 02/06/10 10:44 AM
My amp in my 2004 went out about a year ago. Does anyone know the part number or recommend another amp I can replace it with or can direct me in the right direction? Don't want to pay the dealership the $700 they quoted me to fix and don't know too much about this but MISS MY MUSIC!
Title: Re: Bad BOSE Amp 2004
Post by: avalanched2004 on 10/13/10 09:14 AM
I think mine is gone too, still looking for a part number..
Title: Re: Bad BOSE Amp 2004
Post by: bethg64 on 10/13/10 10:24 PM
 I think this is where I got my new one for like $175 ..  http://www.gmpartsdirect.com/ (http://www.gmpartsdirect.com/).  My part number was 15267751. 
Title: Re: Bad BOSE Amp 2004
Post by: avalanched2004 on 10/14/10 06:58 AM
Thanks, now I just need to find the exact part number of mine to replace.  Do you have to use the exact one?
Title: Re: Bad BOSE Amp 2004
Post by: bethg64 on 10/14/10 07:13 AM
If you go to the gm site I gave you,email them. They will want your VIN number. Then they will respond with the part number for your vehicle.
Title: Re: Bad BOSE Amp 2004
Post by: avalanched2004 on 10/14/10 01:29 PM
They replied with the same part number 15267751.  So once you replaced the amp everything was good?  Did you remove the console or go through the back?
Title: Re: Bad BOSE Amp 2004
Post by: bethg64 on 10/14/10 05:54 PM
Yes works great now!  Definitely cheaper than what the dealer quoted me.  I went in through the console. Had to to get to the amp and unscrew everything. Then slid it in from the back. 
Title: Re: Bad BOSE Amp 2004
Post by: avalanched2004 on 10/25/10 06:12 AM
Got the new amp off Amazon for $207.  Removed rear console and center console door.  Replaced amp in about 30 minutes.  Works great and now I have back speakers again too.  Thanks everyone for the help.

Title: Re: Bad BOSE Amp 2004
Post by: kycucv on 05/12/11 01:41 AM
Thanks for this post... I too  :thumbsup: 2004 avalanche/ Left the sunroof open/thunderstorm over night/ open the door and relize i left the sunroof open.
we got at least an inch of rain. The rear speakers were humming and cracking.  the rear stereo was all gibberish across the screen. I pulled the stereo fuse.  shop vac and fans to dry it out. 3 speakers were out.  passenger front was working but then quit. All the fuses are good.
Looks like i need an Amp.
Title: Re: Bad BOSE Amp 2004
Post by: kycucv on 05/12/11 09:14 AM
Ok im at the amp.  I tested the Orange power wire. Im getting power. How do I know if its a bad amp. Where else should i test for voltage?  Do I need to take apart the door and see if im getting power to the speaker?
Title: Re: Bad BOSE Amp 2004
Post by: CaptDeth on 05/12/11 08:29 PM
If your getting power to the amp chances are its the amp or your deck also got wet and it dead (much less likely).
Title: Re: Bad BOSE Amp 2004
Post by: ohiobellboy on 05/12/11 10:14 PM
Try the wet cell phone trick. Pull the amp, put it in a big bag of rice for a few days and see if it pulls all the moisture out. Seal the bag up real good. I always doubted this until my stepson dropped his phone in a creek and did it. His phone started working again after a day in the bag.
Title: Re: Bad BOSE Amp 2004
Post by: kycucv on 05/13/11 04:00 AM
I found out you can put bleech on those wetness indicators in your cell phone and turn them white again so that the phone company will replace your phone.  If they see red they know you got it wet and your out of waranty. 
It would be nice if i could just dry it out.  I have it sitting infront of a hair dryer, I will try it out in an hour and let you know if it worked.
Title: Re: Bad BOSE Amp 2004
Post by: kycucv on 05/13/11 04:21 AM
Also to remove it was easy.  took the cup holder out.  took out strage bucket. opened back of console. got the amp bolts out, bent down the metal tabs pulled it out.
Here is a short cut.
Amp has 4 bolts. 2 in the back are exposed, easy to get to. The silvar metal bracket over the Amplifier, hidding the front 2 bolts.... Drill 2 holes thru, over the bolts so you can access /put a driver and socket thru the holes. Saves about 3 hours.


Read more: http://wiki.answers.com/Q/Discuss:How_do_you_remove_a_bose_amp_from_a_chevrolet_sil verado#ixzz1MFpz6lnZ
Title: Re: Bad BOSE Amp 2004
Post by: kycucv on 05/13/11 04:31 AM
My amp # on the sticker on back  15054672
Title: Re: Bad BOSE Amp 2004
Post by: kycucv on 05/26/11 01:54 AM
My research says my amp was problematic and to replace my amp with  part # 15267751.  Was there a recall? I probably already know the answer (NO) Has gm replace a known problematic amp not under warranty.

Is there a mod I can do to prevent my new amp from getting wet if I accidentally leave the sunroof open again.  The Diabolical sob engineers made a hole in that metal bracket that channels water right on top of the amp. ???
Title: Re: Bad BOSE Amp 2004
Post by: CaptDeth on 05/29/11 07:49 PM
With the sunroof closed just pull the fuse for it...lol...sorry, couldn't resist that one.
Title: Re: Bad BOSE Amp 2004
Post by: Kevinka on 09/20/13 06:52 PM
Do the Bose amps need to be programmed ? Got a used one from a truck yesterday
Pulled it in and nothing ? Put my old one back in and everything works! I didn't leave
My sunroof open! I have feedback through my speakers so wanna replace it for that ?
Title: Re: Bad BOSE Amp 2004
Post by: ohiobellboy on 09/21/13 05:27 AM
Do the Bose amps need to be programmed ? Got a used one from a truck yesterday
Pulled it in and nothing ? Put my old one back in and everything works! I didn't leave
My sunroof open! I have feedback through my speakers so wanna replace it for that ?
Nope.