Please login or register.

Login with username, password and session length
Advanced search  

News:

Keep CAFCNA Alive! Become a Supporting Member Today!

Pages: [1]   Go Down

Author Topic: ABS engages when stopping  (Read 4580 times)

0 Members and 1 Guest are viewing this topic.

rickshaw

  • Full Member
  • ***
  • Offline Offline
  • Posts: 57
ABS engages when stopping
« on: 10/01/08 06:12 PM »

I recently replaced the front and rear brake pad on my 02 w/147K miles.  The front has Power Slot rotors and Hawk Pads.  Recently the ABS kicks in after a slow stop or and the end of a regular stop.  The ABS light is NOT on.

What could be causing this issue?  A bad EBCM?

Thanks to all for your help!
Logged
02' LPM Z71, K&N drop in filter w/airbox mods, 144K strong!  Just got Gatorback'd!

MS03 2500

  • CAFCNA 2017 Premium Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 37,268
Re: ABS engages when stopping
« Reply #1 on: 10/01/08 06:17 PM »

Could be a speed sensor going bad, next time see if the ABS light flashes when it happens.

And if you can tell if it's from the front or rear.
Logged
2003 2500

rickshaw

  • Full Member
  • ***
  • Offline Offline
  • Posts: 57
Re: ABS engages when stopping
« Reply #2 on: 10/01/08 06:21 PM »

Thanks from a former SE Michigander!
Logged
02' LPM Z71, K&N drop in filter w/airbox mods, 144K strong!  Just got Gatorback'd!

MS03 2500

  • CAFCNA 2017 Premium Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 37,268
Re: ABS engages when stopping
« Reply #3 on: 10/01/08 06:24 PM »

Thanks from a former SE Michigander!

That's right you were, now I remember ya. How's life in FL
Logged
2003 2500

JSal69

  • CAFCNA 2004 Supporting Member
  • Full Member
  • *
  • Offline Offline
  • Posts: 3,769
  • LI/NYC Chapter Decals On Sale Now - $6 each
Re: ABS engages when stopping
« Reply #4 on: 10/01/08 06:25 PM »

I just noticed the exact same issue with my AV.

It started on a day when it was wet out, but I was going extremely slow when applying the brake.

I noticed it again today and it was sunny and dry.

Only happens when applying the brake at very slow speeds.

I'll have to look into it and post up what I find.

If you find out anything first please post up.
Logged
'04 Arrival Blue, WBH, Z71, SS Emblems, SS Headrests, Chrome SS Silverado Rims & SS White Face Gauge Cluster w/Trans Temp, Denali Dash Bezel, Many Chrome Parts, Born-On-Date 11/28/03, Adoption Date 01/02/04, Member Of The A.B.N.

"THOUGH I DRIVE THRU THE VALLEY OF RICE, I SHALL FEAR NO IMPORT... FOR TORQUE ARTE' WITH ME..."

JSal69

  • CAFCNA 2004 Supporting Member
  • Full Member
  • *
  • Offline Offline
  • Posts: 3,769
  • LI/NYC Chapter Decals On Sale Now - $6 each
Re: ABS engages when stopping
« Reply #5 on: 10/01/08 06:27 PM »

Could be a speed sensor going bad, next time see if the ABS light flashes when it happens.

And if you can tell if it's from the front or rear.

I looked for the light when it happened to mine but it wasn't lit.

Mine feels as if it's the right front.

Trannyman replaced my right front wheel bearing a couple of months ago and the ABS was on at that time.

The wheel bearing was extremely bad, so they might be related.
« Last Edit: 10/01/08 06:29 PM by JSal69 »
Logged
'04 Arrival Blue, WBH, Z71, SS Emblems, SS Headrests, Chrome SS Silverado Rims & SS White Face Gauge Cluster w/Trans Temp, Denali Dash Bezel, Many Chrome Parts, Born-On-Date 11/28/03, Adoption Date 01/02/04, Member Of The A.B.N.

"THOUGH I DRIVE THRU THE VALLEY OF RICE, I SHALL FEAR NO IMPORT... FOR TORQUE ARTE' WITH ME..."

MS03 2500

  • CAFCNA 2017 Premium Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 37,268
Re: ABS engages when stopping
« Reply #6 on: 10/01/08 06:30 PM »

The dealer can scan it and see if one sensor is reading wrong. I remember one member had one that was reading 30 MPH standing still.
Logged
2003 2500

02avi

  • Full Member
  • ***
  • Offline Offline
  • Posts: 52
  • Mean Green Avi
Re: ABS engages when stopping
« Reply #7 on: 10/02/08 05:23 AM »

I had this problem a couple months ago. Went to my local mechanic to try to figure out what sensor it was and when we took it for a test drive it never did it. But I ended up changing both of my wheel bearings and haven't had the problem since. Not to fun when your trying to stop and the abs is kicking in.
Logged
2002, Z71, ambers, wig wag, Rancho 9000xl adjustable shocks, chrome stainless steel lund bug deflector, chrome door handles, chrome cladding letters, chrome tailgate letters, four fender flares, chevy molded mud flaps, more to come...

rickshaw

  • Full Member
  • ***
  • Offline Offline
  • Posts: 57
Re: ABS engages when stopping
« Reply #8 on: 10/02/08 05:51 PM »

That's right you were, now I remember ya. How's life in FL

All's good down here, but I'll always be a downriver rat!  And I'm going to see the Kid down here tomorrow night.

I'll be driving the Av tomorrow and will look for the light.  Where is the speed sensor?  On the back of the caliper?

Thanks to all for your posts!
Logged
02' LPM Z71, K&N drop in filter w/airbox mods, 144K strong!  Just got Gatorback'd!

Waz

  • CAFCNA 2004 Supporting Member
  • Full Member
  • *
  • Offline Offline
  • Posts: 1,677
  • Some times you just have to grin and bear it.
Re: ABS engages when stopping
« Reply #9 on: 10/02/08 06:19 PM »

This is sounding a lot like the '02 recall for corroded wheel speed sensors.

Brake Recall Front Wheel Sensor
Logged
'04 1500 2wd, SBM, cladded

MS03 2500

  • CAFCNA 2017 Premium Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 37,268
Re: ABS engages when stopping
« Reply #10 on: 10/02/08 06:34 PM »

The fronts are in the front bearing hub and the rear is near the parking brake on the axle.
Logged
2003 2500

rickshaw

  • Full Member
  • ***
  • Offline Offline
  • Posts: 57
Re: ABS engages when stopping
« Reply #11 on: 10/03/08 11:33 AM »

Waz - thanks for your post, I think we're right on the money but FL is not listed under the recall.

As you can see in my signature, my Av is parked 4-5 days at a time completely exposed to wind, sand and salt.  For example, my brake lines corroded to the point where they broke on the rack while replacing my tires. 

I drove the it today and the ABS still came on, but not as often than before.  What is involved in cleaning/replacing the speed sensors?  How much do they cost?

Thanks all!
Logged
02' LPM Z71, K&N drop in filter w/airbox mods, 144K strong!  Just got Gatorback'd!

Waz

  • CAFCNA 2004 Supporting Member
  • Full Member
  • *
  • Offline Offline
  • Posts: 1,677
  • Some times you just have to grin and bear it.
Re: ABS engages when stopping
« Reply #12 on: 10/05/08 05:26 PM »

Here's another link to a thread with some TSBs that deal with the ABS light and system.

TSB's: Brakes
Logged
'04 1500 2wd, SBM, cladded

JSal69

  • CAFCNA 2004 Supporting Member
  • Full Member
  • *
  • Offline Offline
  • Posts: 3,769
  • LI/NYC Chapter Decals On Sale Now - $6 each
Re: ABS engages when stopping
« Reply #13 on: 10/16/08 05:42 AM »

Had my AV up at trannyman's shop recently for some warranty work.

While there he changed the sensor for the left front wheel.
We had recently done the hub on the right & it comes with a new sensor.

Problem gone, and all covered by extended warranty.


Logged
'04 Arrival Blue, WBH, Z71, SS Emblems, SS Headrests, Chrome SS Silverado Rims & SS White Face Gauge Cluster w/Trans Temp, Denali Dash Bezel, Many Chrome Parts, Born-On-Date 11/28/03, Adoption Date 01/02/04, Member Of The A.B.N.

"THOUGH I DRIVE THRU THE VALLEY OF RICE, I SHALL FEAR NO IMPORT... FOR TORQUE ARTE' WITH ME..."

rickshaw

  • Full Member
  • ***
  • Offline Offline
  • Posts: 57
Re: ABS engages when stopping
« Reply #14 on: 10/25/08 01:17 PM »

I just pulled my sensors and they were pretty gunked up.  Cleaned & re-installed them and the problem feels worse.

What are the odds of having two bad sensors?

Rich
Logged
02' LPM Z71, K&N drop in filter w/airbox mods, 144K strong!  Just got Gatorback'd!
Pages: [1]   Go Up
 

Page created in 0.12 seconds with 24 queries.