Home Resources Forums Nationals Meets Store
07/23/14 12:39 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Welcome to the Chevy Avalanche Fan Club of North America

Become a Supporting Member

Visit the CAFCNA General Store

 
   Home   Help Search Login Register Bookmark  
Advertisement
Put your advertisement image here...


Advertisement
 
Pages: [1]   Go Down
  Print  
Author Topic: Turn signal problem  (Read 3885 times)
0 Members and 1 Guest are viewing this topic.
mantisgt
New Member
*
Offline Offline

Posts: 6


Awards
« on: 08/23/09 09:02 AM »

Can anyone help please?

When I indicate right the truck dose 3 normal flashes then flashes quickly. Sometimes if you use the power fold function it works fine for 1 or 2 times than the fault returns. All the bulbs are working correctly.

Thanks
Ian

Logged
Tango Chaser
CAFCNA 2009 Supporting Member
Full Member
*
*
*
*
*
Offline Offline

Posts: 8,369


Awards
« Reply #1 on: 08/23/09 09:18 AM »

If your using LED bulbs, that would explain the hyper flash.

If not, I'd start by checking the flasher, and wires for a short.

I don't know
Logged
Tdybr27
CAFCNA 2003 Supporting Member
Full Member
*
Offline Offline

Posts: 5,158


Good bye ol' pal.


WWW Awards
« Reply #2 on: 08/23/09 09:52 AM »

Replace your blinker fluid?  I don't know
































 
Logged

Gone but not forgotten.   Good bye old pal.
anglarry04
Full Member
*****
Offline Offline

Posts: 1,845


No more Avalanche...traded for a '11 Traverse


Awards
« Reply #3 on: 08/23/09 09:57 AM »

Can anyone help please?

When I indicate right the truck dose 3 normal flashes then flashes quickly. Sometimes if you use the power fold function it works fine for 1 or 2 times than the fault returns. All the bulbs are working correctly.

Thanks
Ian



so yeah, modded turn sigs or stock?
Logged

2002 1500 Forest green Z71-traded
2004 1500 Sunburst Orange Metallic Z-71-Traded for
2008 1500 Granite Blue LT-Traded for
2011 Traverse LT Red Tint Jewel-current
2006 Trailblazer LT-Wifes-traded 31 Mar for
2008 Tahoe LT1 Ruby Red Metallic
1995 Honda Civic with Acura Type R swap-My project hot rod
mantisgt
New Member
*
Offline Offline

Posts: 6


Awards
« Reply #4 on: 08/23/09 10:00 AM »

stock, but I have power fold and indicators in the glass
Logged
AZAvy
CAFCNA 2011 Supporting Member
Full Member
*
*
*
*
*
*
Offline Offline

Posts: 231



Awards
« Reply #5 on: 08/23/09 11:17 AM »

I have power fold and indicators in the glass

 Huh what exactly is "power fold"
Logged

- Dan
2007 Gold Mist 6.0L LTZ
After the battle: www.woundedwarriorproject.org
adamjeeps
CAFCNA 2009 Supporting Member
Full Member
*
Offline Offline

Posts: 304



Awards
« Reply #6 on: 08/23/09 11:51 AM »

Are you using the lane change feature (a quick blip of the turn signal that gives 3 blinks)?  I had a car that gave me fits when I would accidentally activate that feature and then try to put my regular turn signal on.

Why are you using the power fold mirrors when turning?
Logged

GONE BUT NOT FORGOTTEN: 2007 Black LT3 Z71 4x4 Maglite Mod Antenna Delete Mid-Deck Headrest Mod Onfair Headrest DVDs - Traded for:
2013 Lincoln MKT Ecoboost
ohiobellboy
CAFCNA 2008 Supporting Member
Full Member
*
*
Offline Offline

Posts: 7,055


2 Eagles


Awards
« Reply #7 on: 08/23/09 12:00 PM »

I guess I'll chime in here. If I understand correctly, after you cycle your power fold mirror a few times, the blinkers work normal? Sounds like you've got some wiring issues in there. I would start with the connections inside the doors going to the mirrors. You'll have to pull the panels off to get to it. It also could be a wire going to the mirror itself from inside the door panel starting to break.
Logged

Avy #1 - '04 Z71 Cladded (dark blue metallic) Purchased 9/07 with way too many mods to list. Current mileage 169,*** Nice weather only now.
Avy #2 - '05 Z71 WBH (Bermuda Blue) Twiggy purchased 11/11 Current mileage 151,*** Now used as my winter beater
Avy #3 - '05 Z71 Cladded (Bermuda Blue) Purchased 9/12 as a daily driver for Twiggy. A few mods. Current mileage is 142,***
Other Summer toy - 2011 FLTRUSE (Slate/Black) also called a CVO Road Glide Ultra (Only made one year) Lots of fun on two wheels!
ygmn
Administrator
Full Member
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
Offline Offline

Posts: 31,343


Insert Funny Text Here _______________ .


Awards
« Reply #8 on: 08/24/09 05:15 AM »

Check for bad bulb as well
Logged

Thread Killer ... After I post they die?
2002 Pewter Z66 - Sept 2001
CAFCNA Album
LSU BABY!
YANKEES BABY!
SAINTS BABY!
twmac
Full Member
***
Offline Offline

Posts: 132


AVY


Awards
« Reply #9 on: 09/13/09 10:32 AM »

i have this exact problem!  its super irritating

I will activate my indicator and it will blink normally a few times then it will start blinking at a significantly faster rate (twice as fast?) for no reason.  I also have the power folding mirrors and glass indicator.   I have not experienced it in a few months though... but then again, I stopped using them because it was so agitating.  i'll start using em again and see if cycling the auto folding works.
Logged

07 avalanche LTZ
ca2kjet
Full Member
****
Offline Offline

Posts: 518


something secret steers us


Awards
« Reply #10 on: 12/25/09 09:39 AM »

Had this issue this past weekend. Turned out to be a dead rear left turn signal bulb. Was doing it randomly and then I guess once it was completely dead it always was blinking fast. Replaced the bulb and the hyper blinker went away.
Logged


Black on Black - 2007 Avalanche 4x4 LT3 Z71
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2011, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.082 seconds with 27 queries.
Official SEMA Member ChevyAvalancheFanClub website are the rightful owners as indicated in the ALT TXT tags provided.  Chevrolet, Chevy, Avalanche, PRO-TEC, PASSlock, Midgate, the Chevrolet bowtie logo, Avalanche logo, and their images are registered trademarks of the General Motors Corporation and are used with kind permission as approved by Chevrolet Public Relations, Chevrolet Brand Management, and the Chevrolet Legal Department (thanks Chevrolet!).  OnStar and it's logo are the property of OnStar.  XM, XM Radio, and the XM logo are property of XM Radio.  I'm just a little guy so don't even think about suing me.  It's recommended you read the Privacy Policy and Terms of Use of this website.  The Chevrolet Avalanche Fan Club of North America is a proud member of SEMA, the Specialty Equipment Market Association.  All content appearing on this is protected under international copyright , 2002 to 2008, All Rights Reserved