Please login or register.

Login with username, password and session length
Advanced search  

News:

Keep CAFCNA Alive! Become a Supporting Member Today!

Pages: [1]   Go Down

Author Topic: 04 AV AC not working  (Read 181 times)

0 Members and 1 Guest are viewing this topic.

zman537

  • New Member
  • *
  • Offline Offline
  • Posts: 8
  • I love the Chevy Avalanche
04 AV AC not working
« on: 08/08/18 03:04 PM »

Hey this is my first post, I have done every search on this forum, and when I  think I found the solution I run to the parts store and buy the part but no victory.
I have a 2004 AV that all the sudden started blowing hot air. I shut the truck off and started it again which seemed to work for about 10 min then right back to hot air.
The clutch is engaging, The line are cold, water is dripping out of that drainage hose from the fire well, so it isnt plugged.

Here is a list of things I have done:
Charged with R134 from autozone- It did read low on the gauge- I followed the direction on the can, still no changes.
Replaced Cycle switch with brand new one- still no change.
I replaced both Door blend actuators, so yes I tore dash apart and replaced the one up top, and the one down by the feet on the passenger side - no change
I did find a walk through on how to recalibrate or reset the door blend actuators by turn on, pushing auto on the control head then removing the HVAC-ESC fuse and plugging it back and then turning truck on. the truck goes through the recalibrate and you can hear the doors open and close. but still no Cold air. The buttons on the control head work, so I can switch between dash vent, floor vents and main vents without any issues.

I checked all the fuses- nothing is blown.

I have spent about 300 dollars so far and cut up every finger I have tearing apart that stupid dash. I dont know what to do next.

 :help:




« Last Edit: 08/08/18 03:06 PM by zman537 »
Logged

Big Blockhead

  • CAFCNA 2007 Supporting Member
  • Full Member
  • *
  • Offline Offline
  • Posts: 975
  • If at first you don't succeed.... pay someone
Re: 04 AV AC not working
« Reply #1 on: 08/08/18 09:39 PM »

How about the air temp sensor?
Assuming you have climate control the sensor is what everything is controlling to.  If the system thinks it's cold..... well..... let's crank up the heat!!

The monkeys at the dealership inadvertently disconnected the sensor in our Z71 and it would turn the truck into a meat locker.
Logged
'05 2500 Dark Grey Metalic conceived on Sept 11, 2004- Born Oct 30,2004- Allowed to come home 6hrs after delivery-Moms doing fine. amber FT/DRLs-4 on high-Fogs on high-VR Straps-Z85 decals from Tribal Av-Carriles bowtie-Enkieavalanche four fenders-TnT diamond plate steps-LOF-Fender plug-Cup Holders in rear bumper-Maglight Mod-6"ProComp lift-315/70/17BFG AT KO's on polished and chromed H2 wheels-Westin ovals-HP tuner-2002 roof rack-Prodigy Brake Controller

ohiobellboy

  • CAFCNA 2008 Supporting Member
  • Full Member
  • *
  • *
  • Offline Offline
  • Posts: 7,568
  • 2 Eagles
Re: 04 AV AC not working
« Reply #2 on: 08/09/18 03:37 AM »

When you do the reset by pulling the fuse under the hood,,, Are you starting it and not touching it for a few minutes to let it go through it's full process?
Logged
Avy #1 - '04 Z71 Cladded (dark blue metallic) Purchased 9/07 with too many mods to list. . SOLD 6/21/15
Avy #2 - '05 Z71 WBH (Bermuda Blue) Twiggy purchased 11/11 Current mileage 160,*** Now used as my winter beater SOLD 6/2-/17
Avy #3 - '05 Z71 Cladded (Bermuda Blue) Purchased 9/12  for Twiggy. A few mods.  TRADED 3/10/16
Other Summer toy - 2015 FLTRUSE (Abyss Blue/Crushed Sapphire)  also called a CVO Road Glide Ultra. Lots of fun on two wheels
2012 BMW 535i with XDrive

zman537

  • New Member
  • *
  • Offline Offline
  • Posts: 8
  • I love the Chevy Avalanche
Re: 04 AV AC not working
« Reply #3 on: 08/09/18 08:52 AM »

How about the air temp sensor?
Assuming you have climate control the sensor is what everything is controlling to.  If the system thinks it's cold..... well..... let's crank up the heat!!

The monkeys at the dealership inadvertently disconnected the sensor in our Z71 and it would turn the truck into a meat locker.

So I may have to buy the control head?? I was hoping someone has a cheaper idea.
Logged

zman537

  • New Member
  • *
  • Offline Offline
  • Posts: 8
  • I love the Chevy Avalanche
Re: 04 AV AC not working
« Reply #4 on: 08/09/18 08:52 AM »

When you do the reset by pulling the fuse under the hood,,, Are you starting it and not touching it for a few minutes to let it go through it's full process?
[/quote

Yes I let it go for about 4 minutes and didn't touch a thing. It goes through the reset process. But still doesn't blow the cold air
Logged

MS03 2500

  • CAFCNA 2017 Premium Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 37,360
Re: 04 AV AC not working
« Reply #5 on: 08/09/18 10:04 AM »

Was the battery dead or disconnected when this started?
Logged
2003 2500

zman537

  • New Member
  • *
  • Offline Offline
  • Posts: 8
  • I love the Chevy Avalanche
Re: 04 AV AC not working
« Reply #6 on: 08/09/18 02:38 PM »

Was the battery dead or disconnected when this started?
Nope I had been driving that day for about an hour. No disconnect from battery or dead battery prior to driving
Logged

zman537

  • New Member
  • *
  • Offline Offline
  • Posts: 8
  • I love the Chevy Avalanche
Re: 04 AV AC not working
« Reply #7 on: 08/09/18 02:44 PM »

How about the air temp sensor?
Assuming you have climate control the sensor is what everything is controlling to.  If the system thinks it's cold..... well..... let's crank up the heat!!

The monkeys at the dealership inadvertently disconnected the sensor in our Z71 and it would turn the truck into a meat locker.

Ok, so I tried a YouTube search, couldn't find one for the avalanche, but where is this located
Logged

zman537

  • New Member
  • *
  • Offline Offline
  • Posts: 8
  • I love the Chevy Avalanche
Re: 04 AV AC not working
« Reply #8 on: 08/09/18 06:13 PM »

Also I noticed that I really don't have any temperature change at all when I switch it to heat. So I guess this does
sound like the control head I guess????
Logged

Raiders91340

  • Member
  • **
  • Offline Offline
  • Posts: 23
  • I love my Avy
Re: 04 AV AC not working
« Reply #9 on: 08/09/18 07:58 PM »

Is your voltage reading ok? Alternator working fine? The resistor for the AC, is it old? If its auto climate control, these resistors are notorious for going out. Happened to me.
Logged

zman537

  • New Member
  • *
  • Offline Offline
  • Posts: 8
  • I love the Chevy Avalanche
Re: 04 AV AC not working
« Reply #10 on: 08/12/18 07:38 AM »

Ok so I found a sensor in the headliner above the driver's side. I don't have any temperature difference at all when I change from hot to cold. When I unplugged this sensor I all the sudden had hot air, but still no ac. Could it be that sensor. I feel like I'm just gonna throw money at this thing until I find it.
Logged

zman537

  • New Member
  • *
  • Offline Offline
  • Posts: 8
  • I love the Chevy Avalanche
Re: 04 AV AC not working
« Reply #11 on: 08/12/18 07:53 AM »

Is your voltage reading ok? Alternator working fine? The resistor for the AC, is it old? If its auto climate control, these resistors are notorious for going out. Happened to me.

That actually happened in my trailblazer, but the fan stopped working when it went out. The fan speed still works on the avalanche, so does the resister also have to do with hot and cold? I haven't checked the alternator.
Logged

redheadedrod

  • CAFCNA 2017 Supporting Member
  • Full Member
  • *
  • *
  • Offline Offline
  • Posts: 2,693
  • 2003 Z71
Re: 04 AV AC not working
« Reply #12 on: 08/12/18 09:45 PM »

You could do the simple thing and take it to a mechanic that deals with AC stuff.. they will likely find the issue in less than a half hour and charge you less than the next part you change that wasn't it....

Rodney
Logged
2003 Cladded Black Z71 - PC installed otherwise mostly stock.
4 Light Brake/Turnsignal
All on high and FTDRL (BCM friendly version)
Pages: [1]   Go Up
 

Page created in 0.088 seconds with 24 queries.