Chevy Avalanche Fan Club Forum

Avalanche Owners Zone => Chevy Avalanche Audio/Video & Electronics => A/V: Parking assist systems => Topic started by: spidey on May 21, 2019, 19:28:39 PM

Title: In mirror backup camera display stopped
Post by: spidey on May 21, 2019, 19:28:39 PM
Always one of my fears, when this stops displaying.  Happened today, regular drive to work, went to back up, no display in my mirror.  Not even a black screen, just nothing. 

What are some troubleshooting to do for this.  I use the tailgate like normal, shut it like normal.  Its a 2012 Avy LT with the tow package
Title: Re: In mirror backup camera display stopped
Post by: spidey on May 27, 2019, 19:46:14 PM
So I took the back plastic off and checked connections, everything seems fine.  I even disconnected and reconnected the camera inside the tail gate,  Fuse seems fine, but still no camera.   Can these just go, because backing up without one with the Avy blind spot isn't something Im a fan of.  What else can I check
Title: Re: In mirror backup camera display stopped
Post by: MS03 2500 on May 28, 2019, 15:00:11 PM
I think the. Module for it is under the passenger seat.
Title: Re: In mirror backup camera display stopped
Post by: spidey on May 30, 2019, 07:14:57 AM
I think the. Module for it is under the passenger seat.

So what would I be looking for as an issue then with this module.  I dont want to just randomly replacing parts, especially when it happened right after I shut the tail gate and it started.  As in somethings up with the camera.  The manual says

"The RVC system display in the rearview mirror may turn off or not appear as expected due to one of the following conditions. If this occurs the left indicator light on the mirror will flash."

A slow flash may indicate a loss of video signal, or no video signal present during the reverse cycle.

Mine does slow flash.  Wonder if the dealer has a spare camera to test.  I want to try simple first before digging into a module   The module controls the entire rear parking, and my back up sensors work fine
Title: Re: In mirror backup camera display stopped
Post by: spidey on May 30, 2019, 07:44:11 AM
So got off the phone with a GM tech.  The Park Aid control module underneath the passenger seat controls the parking sensors.

So for anyones future info, if you have a camera in your rear view mirror, that module doesnt have anything to do with the camera.    If it is the camera thats in the Navigation area of your Stereo, then it does.

So its looking like a failed camera, since it was so random and stopped suddenly.  But if I buy one and its not, then I cant return it.   Not sure what else it can be, no loose connections I can see.

The Camera module part number us 20985078
Title: Re: In mirror backup camera display stopped
Post by: spidey on June 5, 2019, 13:54:04 PM
How does one remove the original back up camera?  There are no outside screws on the tailgate handle, and inside the tail gate there is very little access to get to it.  Does the entire metal panel come off the back of the tail gate?
Title: Re: In mirror backup camera display stopped
Post by: spidey on June 11, 2019, 07:25:18 AM
SO broke down and bought a camera.  After rechecking fuses and following wiring I can see, I dont see it being something else since it just quit.  Taking it to a shop to trace it will be probablyu minimum $100 anyway

Problem is the place I bought it from says, once the package is opened, you cant return it, since it electronic.  Ok, thats fine.   So I picked it up and the guy opens the box to check it.   Its not in plastic, just the box.  So i said, I thought if it was opened I cant return it.   You just opened it.    Now he said, if its plugged in you cant.   How will you know I plug it in, its a simple plug in, there would be no proof. 
Title: Re: In mirror backup camera display stopped
Post by: ca2kjet on June 11, 2019, 14:56:08 PM
If you still need it, I can get you the removal instructions for the camera. Let me know.
Title: Re: In mirror backup camera display stopped
Post by: spidey on June 12, 2019, 07:27:19 AM
If you still need it, I can get you the removal instructions for the camera. Let me know.

Yes please, even with the back plastic panel off, I cant see where to get to for any internal screws
Title: Re: In mirror backup camera display stopped
Post by: ca2kjet on June 12, 2019, 20:17:16 PM
Yikes, I was not expecting the service manual to be so vague. Sorry for the lousy image of the page. After removal of the trim, it looks like there's two nuts that you can presumably access via openings in the sheet metal (Are there even openings?). What's confusing here is that the image they show is from the other side facing the latch.

http://www.chevyavalanchefanclub.com/gallery/albums/userpics/44227/rear-camera-diagram.jpg
(http://www.chevyavalanchefanclub.com/gallery/albums/userpics/44227/rear-camera-diagram.jpg)
Title: Re: In mirror backup camera display stopped
Post by: spidey on June 13, 2019, 07:13:13 AM
Yikes, I was not expecting the service manual to be so vague. Sorry for the lousy image of the page. After removal of the trim, it looks like there's two nuts that you can presumably access via openings in the sheet metal (Are there even openings?). What's confusing here is that the image they show is from the other side facing the latch.

http://www.chevyavalanchefanclub.com/gallery/albums/userpics/44227/rear-camera-diagram.jpg
(http://www.chevyavalanchefanclub.com/gallery/albums/userpics/44227/rear-camera-diagram.jpg)

yes there are openings, but the kind where you need really long fingers to do anything.  Thanks for the info, see what I can do.  Before I even attempt this Ill test the new camera, at least the connector is easy to access
Title: Re: In mirror backup camera display stopped
Post by: spidey on June 26, 2019, 19:56:50 PM
Well unfortunately a new camera did not fix the issue, same thing.  Mirror light blinks slow, no image.  Which means a connection issue.  Im not sure where to start, I traced and done see any broke wires or loose connectors.  I traded fuses as well with other 10 amp and same thing
Title: Re: In mirror backup camera display stopped
Post by: spidey on June 28, 2019, 06:41:15 AM
Well after a few weeks, suddenly my mirror light was blinking weird, and the camera turned on.  Flashed off, then on, then funky, then on.  So now I know its not the camera for sure, but a short somewhere that healed itself?   At least that will limit the troubleshooting of a fuse or camera,
Title: Re: In mirror backup camera display stopped
Post by: BainMan on June 28, 2019, 06:58:58 AM
Good luck spidey, I wish I could help but I haven't had to face that gremilin yet.
Title: Re: In mirror backup camera display stopped
Post by: spidey on July 2, 2019, 07:05:18 AM
Good luck spidey, I wish I could help but I haven't had to face that gremilin yet.

I do now again, it lasted a few days, now back to the same.  If it is a short, hope its somewhere easy to be found, and not like the headliner or something else
Title: Re: In mirror backup camera display stopped
Post by: spidey on July 5, 2019, 09:59:29 AM
As I suspected it was a broken wire, I just couldnt find it.

$143 later its repaired.   It was the loop by the camera connection, a wire inside was broken.  So it wasnt the camera wires itself, but the wires after the connector in the tailgate at the loop

Thousands of tailgates closes over time, thats why it just went dead.  Ill probably be a little more gentle shutting now.

Fix was a simple splice with heat shrink and away we go.  Cost was tracing the issue

Could I have fixed it, sure, if I knew where it was, but it wasnt an obvious break.

So for future info for anyone, that was the issue