• If you currently own, previously owned or want to own an Avalanche, we welcome you to become a member today. Membership is FREE, register now!

2004 4x4 Avy Transfer Case

fuddsnake

New Member
Joined
Jan 20, 2020
Messages
3
New to the forum.

04 Avy 4x4/5.3L/1500

I am trying to see if ANYONE has done away with the need for the Transfer Case push button tree and TCCM. I am looking specifically to find out if there is someone who has bypassed these two mode selection PITA's, and figured out a way to cross wires, apply voltage to, or whatever.....to be able to engage the transfer case manually. I have the front actuator part figured out, I believe(how to engage/disengage manually)but clarification never hurts....for sure!

Hopefully someone has figured out how to do this, and can share the process and procedure.

Thank you in advance for your time and assistance! Happy Avy owner here! Help me use the ole girls potential...
 

frito

PM 2020
PM 2018
PM 2017
Full Member
Joined
Dec 12, 2013
Messages
2,353
Location
Cincinnati, OH
I don't know how the systems on our trucks work,  it over on the Suzuki forum I learned there is a pump that is activated when fwd a fwd lever is pulled.  This pump is hard to find and expensive.  This is probably way more manual than you are looking for but one person Installed a hand pump (think blood pressure pump squeeze ball) to create the pressure to activate system.  They just routed it got the center console.

I'm sorry, probably not the solution you are dealing but it's the best I have.
 

2004Slickside

Full Member
Joined
Jan 24, 2017
Messages
253
fuddsnake said:
New to the forum.

04 Avy 4x4/5.3L/1500

I am trying to see if ANYONE has done away with the need for the Transfer Case push button tree and TCCM. I am looking specifically to find out if there is someone who has bypassed these two mode selection PITA's, and figured out a way to cross wires, apply voltage to, or whatever.....to be able to engage the transfer case manually. I have the front actuator part figured out, I believe(how to engage/disengage manually)but clarification never hurts....for sure!

Hopefully someone has figured out how to do this, and can share the process and procedure.

Thank you in advance for your time and assistance! Happy Avy owner here! Help me use the ole girls potential...
Encoder motor (electrical) turns a shaft that goes into the TC to select 4WD/2WD positions.  When you push a button, TCCM sees this, starts flashing the push button light, activates the brake release on the encoder motor, and sends directional power to the encoder motor to turn the shaft one way or another.  When the TC has reached the new position, the TCCM sees this through a sensor in the encoder motor.  The TCCM then stops the power to the encoder motor, releases the brake to lock in the new position, illuminates the push button light steady, and locks in the front axle.

All you could do is remove the encoder motor and rig up some sort of manual way to turn the shaft between 4WD HI and 2WD HI.  I believe there are detents in the positions so you could tell where they are.  Of course the system will not work with Auto mode, the 4WD malfunction light will be on, and I'm not sure what it will do to the ABS electrically.  They share some circuits.

Honestly, I think it's a lot of rigging for what you get out of it.  Better to replace both TCCM and encoder motor if you have to after checking wiring and ALL fuses for the system.  It's very easy to diagnose 4WD using a Tech 2, but very difficult without.  Controls very seldom go bad but are often replaced because they are easy and cheap.  Often encoder motor shorts out and this extra current takes out the TCCM.  Also be aware of and look out for corrosion on the TCCM terminals (for the heavy wires going to the encoder motor).

If you get a new TCCM, get a pre-programmed remanufactured unit like a Cardone (not GM) or it will need programming before installation.

Good luck
 

fuddsnake

New Member
Joined
Jan 20, 2020
Messages
3
I have removed the TC motor. And I can easily work the selector switch. However, I can not get it to lock in the front drive shaft. It just goes into low lock 2wd. It seems that there has to be a way to apply voltage to a certain pin, to actually get it to lock in the front shaft...

I wish I had the diagnostic equipment to do this properly, but I need to be able to make it through this winter. I just want to be able to manually engage 4 hi. Any suggestions?
 
Top