Clock Froze

Molon Labe

New Member
So, I replaced my battery in my 2011 LTZ with nav, and afterwards I have not been able to get the clock to work properly. It stays frozen on whatever time I start the truck. I know it still tracks the time properly because if I press any of the buttons on the side of the radio, or turn the power to the radio off, it will refresh the time but immediately freeze again.

I'm at a loss, has anyone had anything like this happen that could maybe shed some light on the issue, and a possible fix? I've tried disconnecting the battery for a while in hopes that the unit will "reset" itself but it doesn't help. The only thing this accomplishes is forgetting the names on all of my saved XM channels.

The truck is solid other than this, 230k miles and runs like a champ!
 

newavguy

PM 2017
PM 2015
SM 2014
PM 2013
PM 2012
SM 2011
SM 2010
SM 2009
SM 2008
SM 2007
SM 2006
Full Member
Try this, turn the radio off then pull the fuse out wait for 1 minute then put the fuse back it
 

BainMan

Full Member
On my 2010 w/ nav anytime the battery is disconnected I have to enter the service menu of the radio to be able to set the time. After that, the clock works fine. I would have no time displayed at all until entering the service menu, your issue seems slightly different but I'm hopeful this will fix yours too.

1. Press Menu
2. Press Display
3. Hold your finger on the imaginary button at the bottom left of the screen (still on the display menu)
4. Enter Code 295660
5. Press Next Page
6. Press Set time.
7. Set that time!

Let us know how your fair! 
Also, if a visual aid helps: https://www.youtube.com/watch?v=bZz3RK_kXgc
 

Molon Labe

New Member
BainMan said:
On my 2010 w/ nav anytime the battery is disconnected I have to enter the service menu of the radio to be able to set the time. After that, the clock works fine. I would have no time displayed at all until entering the service menu, your issue seems slightly different but I'm hopeful this will fix yours too.

1. Press Menu
2. Press Display
3. Hold your finger on the imaginary button at the bottom left of the screen (still on the display menu)
4. Enter Code 295660
5. Press Next Page
6. Press Set time.
7. Set that time!

Let us know how your fair! 
Also, if a visual aid helps: https://www.youtube.com/watch?v=bZz3RK_kXgc
This worked perfectly! Thank you so much for the help! Can a moderator pin this thread for anyone else that may have this issue?
 

BainMan

Full Member
Glad it worked Molon. I can't imagine why a GPS enabled device would not set its own time nor allow the time to be set from the regular menu (option is there, it just doesn't work) every time the battery is disconnected. It irks me because the only logic I can come up with is they get a quick service visit from people not inclined to go find the answer online!
 
Top