Door Locks

1121wayne

New Member
Have a 2003 avalanche, front door lock works perfect but both back door will not lock, you can lock them manually and and can  open them with the switch or remote, just can not lock them. Any ideals
 

newavguy

PM 2017
PM 2015
SM 2014
PM 2013
PM 2012
SM 2011
SM 2010
SM 2009
SM 2008
SM 2007
SM 2006
Full Member
Hi Wayne there are 2 relays for the rear door, I believe they are in the fuse panel on the left side of the dash board, try swapping there and see if they lock.

If that works replace both of them, you may have problems if you replace just one.
 

1121wayne

New Member
MS03 2500: You are right on top of it. Change places with the relays they are locking and unlocking just as they should be. Thank for your advice.  Question am I working off of different contacts when I traded relays.
 

newavguy

PM 2017
PM 2015
SM 2014
PM 2013
PM 2012
SM 2011
SM 2010
SM 2009
SM 2008
SM 2007
SM 2006
Full Member
Nope but I think one of the relays is going bad. Sometimes when you pull them out they reset themselves.
 

newavguy

PM 2017
PM 2015
SM 2014
PM 2013
PM 2012
SM 2011
SM 2010
SM 2009
SM 2008
SM 2007
SM 2006
Full Member
Opps :welcome: to the club
 

newavguy

PM 2017
PM 2015
SM 2014
PM 2013
PM 2012
SM 2011
SM 2010
SM 2009
SM 2008
SM 2007
SM 2006
Full Member
I see you are a new member ftlbs1
:welcome: to the club.

ftlbs1 said:
Had the same problem with my 04. New relay did the trick.
 

avfanatic

New Member
Hi all,

I have the same problem with my 03 Av -- rear doors won't lock -- they will unlock but not lock -- not even when I use the lock switch on the driver's side door.  So, I located the relays and CANNOT GET THEM OUT -- How do I remove the relays?  do you need to use pliers or some such thing?

Thanks for the help.

AvFanatic
 

jlmoore01

SM 2011
Full Member
Ok I am having this problem and I have done all the above switch relays, new relays, even new rear lock actuators. Well I work for a dealer and this is what we found.
If the rear doors don't lock try this and hope you dont have the same issue as me.

With the Drivers door open lock and unlock your doors if the rear doors did not lock
open the fuse door cover on the dash by the drivers door. Place a finger on the relays and lock and unlock the doors, you should feel the relays work.
Now depending on how hard you had your finger on relay the door may or may not lock. if it locked now remove your finger and do it again.
If it didn't lock you will need a new fuse box.

This is whats wrong with mine and its gonna get $$$$$. So I leave the cover off and when I need to lock it I just hold the relay in and lock the doors.
Whenever the wrecking yard near me gets an 03 chevy sub, k1500 or AV im gonna get the box but this is my fix till then.
 

jetfixer737

Full Member
Thanks to you all in this thread! I was about to take my '03 to the dealer for this problem. Mine was slightly different though because my rear doors wouldn't UN-lock. I went down to the dealer and got one of the relays and now all is good again. Strangely though, it was the LOCK relay that got it going again and not the unlock. ??? Both the manual and the decal on the fuse door say the lower is the unlock relay but changing it was no help. I changed the one labeled "lock" and now it works fine.

Maybe I shouldn't question it and just be thankful its working again (y) 
 

jetfixer737

Full Member
Thanks to you all in this thread! I was about to take my '03 to the dealer for this problem. Mine was slightly different though because my rear doors wouldn't UN-lock. I went down to the dealer and got one of the relays and now all is good again. Strangely though, it was the LOCK relay that got it going again and not the unlock. ??? Both the manual and the decal on the fuse door say the lower is the unlock relay but changing it was no help. I changed the one labeled "lock" and now it works fine.

Maybe I shouldn't question it and just be thankful its working again (y)  
 

radoave

SM 2018
Full Member
Well - now i'm having this same issue where my rear locks are locking just fine, but randomly NOT unlocking all of the sudden, so I probably have a bad relay as well.  (At least I hope that its not something more serious!)

So, if I want to swap these relays out, how do you properly remove them from the fuse box panel - as the previous poster asked, do you just pull them out with pliers?    I don't want to break anything...  :)

Thanks!
 

newavguy

PM 2017
PM 2015
SM 2014
PM 2013
PM 2012
SM 2011
SM 2010
SM 2009
SM 2008
SM 2007
SM 2006
Full Member
I would not use pliers, unless you have a needlenose pliers and don't squeeze too hard.

 

shermanjewell

New Member
I have a 2008 Avalanche, same problem rear lock won't open with switch or rke only manually. Someone please point me to the actual location of the relays, I can't find the in either fuse box or in the manual. I've found five door lock fuses but no relays, looked for days!
 
Top