• If you currently own, previously owned or want to own an Avalanche, we welcome you to become a member today. Membership is FREE, register now!

Exterior LED issues

kev2809

Full Member
Joined
Oct 28, 2019
Messages
92
2002 model

added led low and high beams as wells as the fogs and reverse bulbs. nice upgrade.

I'm trying to add the led signals up front. my issues are these.

I bought these auxbeam amber 3157. with the lights on, the 3157 lights but doesn't blink. only the corner light. with the lights off, the 3157 blinks, but the corner one does not. I have a resistor wired in to the the 3157. the corner bulbs do not bother me, I can leave the regular 194 in since it's not much of a difference. but the 3157 does bother me. I want them to work like regular bulbs do. what am I missing?
 

Attachments

  • Screenshot_20210325-184446_Amazon Shopping.jpg
    Screenshot_20210325-184446_Amazon Shopping.jpg
    81.6 KB · Views: 2

Tacocat

Full Member
Joined
Mar 30, 2019
Messages
123
Location
South Fl
Not sure I understand fully, but what I got is that the side lights (amber) are on but don't blink?
Did they before the swap?
Try reversing the polarity on the led by flipping it inside the socket. I had this happen on one of my led swaps. It drove me mad.
If I"m mistaken in what you're saying please clarify. I'll try to help as best as I can.
 

kev2809

Full Member
Joined
Oct 28, 2019
Messages
92
ok thanks for the reply. the corner bulb led is throwing the problem off because I believe they only work 1 way but not both. for example. if I have the bulb one way, it will only blink with the lights off. if I flip the bulb to reverse the polarity, it will come on but not blink. but this issue seems to be a bulb problem. my main issue is the 3157 led bulb. when I install it with no resistor, the corner bulb blinks but hyper, and the 3157 bulb just stays lit. so I obviously add the resistor. it fixes the hyper blink for the 194 corner but the led won't blink. this is lights on. with the lights off, the 3157 led blinks like normal but the corner does not.

the regular bulbs (with lights off) will take turns blinking (3157 and corner 194). with lights on, they both blink at the same time. so I know with regular bulbs it's working fine. just with the led 3157 it will not.

I hope I'm making sense lol.
 

Tacocat

Full Member
Joined
Mar 30, 2019
Messages
123
Location
South Fl
So the regular bulbs alternate blink when lights are off.
Regular bulbs blink simultaneously when lights on.
All my leds are polarity based and work meaning they light up if installed one way. When flipped they don't turn on at all.
So when you tell me they work both ways just not properly I'd suspect the light bulb itself. I just finished my led upgrade and replaced all my exterior bulbs except the puddle lights. Not one of them worked if plugged in backwards.
My only other guess would be the bcm but without testing the circuit I can't say.

Edit: I'll go check my setup later and see if my regular bulbs blink like that and watch the leds too.
 

kev2809

Full Member
Joined
Oct 28, 2019
Messages
92
thanks for ur help! to keep this problem simple, let's ignore the corner bulbs. with resistor wired in, and lights on, the 3157 led does not blink at all, it just stays lit... only blinks with the lights off. if I flip the polarity it does absolute nothing.

what led 3157 are u using? and the corner 194?
 

Tacocat

Full Member
Joined
Mar 30, 2019
Messages
123
Location
South Fl
Not sure I'm much help but I'm trying. Electrical is tough to diagnose without being in front of it.
For everything except my main headlight assembly and fogs the 3157's & 194's bulbs are sylvania.
Ok, so polarity is correct. Now let's troubleshoot...
Go back to the original setup... The incandescent 3157. They turn on and blink as normal, meaning they light up when the truck is on, in drive or park and also if you manually engage the lights, correct?
They blink when you activate the turn signal and so do the amber corners (194). Correct?
The led with a resistor doesn't provide the same output. Correct.

The led bulb remains lit without having the signal interrupted when the blinker is activated with the lights on and blink only when ignition is in the off position and the lights and blinker activated.

I'm inclined to lean to a possible ground issue as that could cause the intermittent behavior in the circuit. If not that maybe something in the bcm isn't deciphering the led. That is to say your wiring job is tight. If you've any doubt with that, go check your work. Come to think of it, maybe the resistor isn't functioning right? Test them with a meter. Swap if needed.
I'm curious what happens if you remove the resistor. I'm not running a resistor in my circuit for any of my leds. My blinkers don't flash improperly and operate as expected and it's an 02 as well.
 

kev2809

Full Member
Joined
Oct 28, 2019
Messages
92
well I checked the resistor with a test light and they had power and ground, but I didn't test with a multi meter. if I put the led in with no resistor the 3157 just stays lit (no blink) and the corner 194 hyper flashes. I'm strongly thinking the bulb is the culprit. do u have any pics of ur slyvania 3157s? u say these don't require resistors? I'd like to see what they look like.
 

Tacocat

Full Member
Joined
Mar 30, 2019
Messages
123
Location
South Fl
They're the Zevo LEDs. Got them off Amazon.
Zevo LEDs
Honestly didn't even care about the resistor at the time I out them in. One of the originals had burned out and the other was dim. As I was installing them I remembered I needed a resistor and just said I'll fix it later but it worked.
 

kev2809

Full Member
Joined
Oct 28, 2019
Messages
92
I ordered me a set and returning the auxbeam ones. should get them by the end of week well see what happens
 

Tacocat

Full Member
Joined
Mar 30, 2019
Messages
123
Location
South Fl
I ordered me a set and returning the auxbeam ones. should get them by the end of week well see what happe
Hope it works for you like it did mine. I will say they are polarity specific despite what they advertise or at least mine are...
 

kev2809

Full Member
Joined
Oct 28, 2019
Messages
92
did u use any leds for the rear? so far I put the reverse lights and live them but I've been hesitant to do the light and signal/brake
 

Tacocat

Full Member
Joined
Mar 30, 2019
Messages
123
Location
South Fl
I've upgraded all my lights to LEDs some zeno others not but still sylvania

Edit: tried to upload a video but the file is too large.
 
Last edited:

kev2809

Full Member
Joined
Oct 28, 2019
Messages
92
got them in they work correctly but do hyper flash no big deal a resistor should fix it. but these 3157s don't have a direct led, only the sides of the bulbs? I bought the ones u posted but in amber (obviously because it's a turn signal). passenger is the led, driver is the original
 

Attachments

  • 20210402_081823.jpg
    20210402_081823.jpg
    160.7 KB · Views: 3
  • 20210402_081817.jpg
    20210402_081817.jpg
    144.9 KB · Views: 3

Tacocat

Full Member
Joined
Mar 30, 2019
Messages
123
Location
South Fl
At least they're working and you can drop a resistor in.
got them in they work correctly but do hyper flash no big deal a resistor should fix it. but these 3157s don't have a direct led, only the sides of the bulbs? I bought the ones u posted but in amber (obviously because it's a turn signal). passenger is the led, driver is the original
Yeah they reflect back upon the assembly and direct the light instead of shining it straight outward.
I used the white and they're the same way. Much brighter and for some reason unknown to me, they just work right. No hyper flash. Never took the time to see why. Happy they work but wondering what's wrong in my lighting system...
The main thing is do you like them?
 

kev2809

Full Member
Joined
Oct 28, 2019
Messages
92
well they're OK. I did get a second set from Amazon that I just tried. they look even better BUT they make the small 194 polarity based. meaning it will blink only with the lights on, if I flip it, it only blinks with the lights off. sucks because this new 3157 is bright! it has leds all around and a straight led
 

Tacocat

Full Member
Joined
Mar 30, 2019
Messages
123
Location
South Fl
well they're OK. I did get a second set from Amazon that I just tried. they look even better BUT they make the small 194 polarity based. meaning it will blink only with the lights on, if I flip it, it only blinks with the lights off. sucks because this new 3157 is bright! it has leds all around and a straight led
Seems like there's something going on with how the lights are made and function with your system if you're getting different results from the lights.
 

kev2809

Full Member
Joined
Oct 28, 2019
Messages
92
yup the auxbeams were similar. only the zenos led functions right but I really like how bright these newer ones are..and the direct amber light.

if I leave these newer 3157s I won't get a corner blink either at night or day, depending on how I position the 194. hmm

the other alternative would be to manually turn my lights on when I drive to have them lit up at all times and function right.....and if I forget it's only daytime and not that big of a deal....
 
Last edited:

kev2809

Full Member
Joined
Oct 28, 2019
Messages
92
I went ahead and installed the newer ones. won't have 194 blinkers with the lights off but no big deal. need to figure out where to permanently put the resistors. I drilled them to the core support and then realized the core support is not metal lol
 

Attachments

  • Screenshot_20210404-084340_Amazon Shopping.jpg
    Screenshot_20210404-084340_Amazon Shopping.jpg
    106.4 KB · Views: 1
  • 20210404_080343.jpg
    20210404_080343.jpg
    163 KB · Views: 0
  • 20210404_080336.jpg
    20210404_080336.jpg
    157.2 KB · Views: 0
  • 20210404_080243.jpg
    20210404_080243.jpg
    160.2 KB · Views: 1
  • 20210404_080236.jpg
    20210404_080236.jpg
    157.9 KB · Views: 1

Tacocat

Full Member
Joined
Mar 30, 2019
Messages
123
Location
South Fl
The lights look good.
For the resistor, I'd put them right behind and under the light with some 3m double sided adhesive. No holes!
 

kev2809

Full Member
Joined
Oct 28, 2019
Messages
92
good point. I'm just worried about them getting hot. these do heat up but I can't imagine a scenario where they blink for so long to where they can heat up and melt something, unless I have my hazards on
 
Top