• If you currently own, previously owned or want to own an Avalanche, we welcome you to become a member today. Membership is FREE, register now!

Mistery plugs behind grill??

ajk2000

Full Member
Joined
Sep 17, 2006
Messages
639
Location
Huntington Beach, CA
I have two plugs behind my grill that dont connect to anything.. they are plugged into holders infront of the radiator...
 

Attachments

  • img025.jpg
    img025.jpg
    37.1 KB · Views: 388
  • img030.jpg
    img030.jpg
    40.3 KB · Views: 384
block heater maybe, I remember reading about those before, but it escapes me right now
 
Theres one on the drivers side and one on the passenger side...  I think the wire colors are differnt on both... but the plugs are the same
 
do you have fog lights??  Thought maybe it was something in the harness that you wont have on your AV.. 
 
i have fogs already...    i was wondering if its for options on upcomming z71 packages..  The wires are to small for a winch..    maybe for lights in the grill.
 
Are you sure thats not the outside air temp sensors they are plugged into ???
 
ajk2000 said:
I have two plugs behind my grill that dont connect to anything.. they are plugged into holders infront of the radiator...
That's your outside air temp sensor.
The General got cheap here and stop supplying the plastic mount holder.
 
ok.. that would explain one of them..  i looked at it to see if it was a thermalcouple but it looked small.. 
i may have to hit them with a heat gun to see if i can get the temp to change...
 
Maybe they use 2 and average the difference ???
 
RENORCR said:
Wow, that's new to me.  :eek:
You actual have two air temp sensors.

I have had my front grill off a number of times.
I have only one and it's located on the driver side.

I have a 2007 LTZ and it has two of these but when my AV was delivered one of the devices was hanging loose and not installed.  When the dealer installed it correctly I was told these were airbag sensors.

Frank
 
I dont think they are airbag sensors..They dont look like any I have ever seen  :D
 
fmcgirt said:
I have a 2007 LTZ and it has two of these but when my AV was delivered one of the devices was hanging loose and not installed.? When the dealer installed it correctly I was told these were airbag sensors.

Frank

Not airbag sensors. Airbag sensors are lower at bumper impact area.
I know at least on mine. It's matches the service manual description for air temp sensors.
 
They are temperature sensors. Both of them. One is for the mirror display and the other is for the auto HVAC control.

Mystery solved.
 
My guess is, when you use your remote start, (keyfob), this second air temperature sensor is the deciding factor as to turn the AC on for cooling or turn the heater (defrost) on. So your Av is either cooled or heated to the pre-set temp. , before you enter your vehicle.
 
[quote author=Bluesnow ]
My guess is, when you use your remote start, (keyfob), this second air temperature sensor is the deciding factor as to turn the AC on for cooling or turn the heater (defrost) on. ???So your Av is either cooled or heated to the pre-set temp. ??, before you enter your vehicle. ??
[/quote]

It does that!? :eek:
 
Actually it is very important for the HVAC to have a reference point when deciding how much cooling or hearing to apply. Without knowing the intake air temperature, it wouldn't know if the cabin air temp was changing because of external temp changes or something that it is doing on its own. In addition, when combined with the sun load sensor (the black dome thingy on your dash near the windshield), the IAT is absolutely necessary to calculate additional cooling because of the sun shining into your truck.

Hope this helps.

-Ed


Tdybr27 said:
Why is the temp sensor for the auto HVAC outside?  Outside temp should have nothing to do with what temp you want inside?
 
Bringing this one back to life for a question:

If an Avalanche has two probes at each side of grille area, and one is for mirror display and other for HVAC, which side of vehicle is for which. Reason I'm asking is my mirror display is becoming inaccurate and I wanted to change the correct probe. The auto HVAC is having no problems, so I assume changing the HVAC is not necessary.
 
Could always unplug one and see which it does... However since others have stated they only have one on the drivers side I would take that as being the mirror one and the passenger side being the one for the automatic HVAC systems.

You could also try swapping sides to see if it makes a difference.

Rodney
 
Back
Top