• June 19, 2020 - We've been making good progress moving into the new forums. Still much to be done. Thank you for your patience and understanding through this process.

Stock radio swap for nav lcd radio

aveduc

Full Member
Ok so I bought a factory 07 head unit with nav, I want to install it to replace the factory radio in my ave, i have the bose amp and rear dvd that it came with, other the getting the dealer to unlock the system after the install. Any one done this before?
 

newavguy

PM 2017
PM 2015
SM 2014
PM 2013
PM 2012
SM 2011
SM 2010
SM 2009
SM 2008
SM 2007
SM 2006
Full Member
It should just work OK after the dealer clears the old VIN

Did you get the antenna for the Nav, post the model number of the new one
 

aveduc

Full Member
its all programmed and installed, i am still working on the 12volt reverse supply wire for the camera. It takes a while to get a gps signal but it eventually does work but its a pain in the ass!
Question is when i enter a destination and hit go, the voice says {please proceed to the destination bla bla} and when i have arrived to the destination the voice comes over the speakers and informs me that i have arrived, BUT it never informs me of up coming turns? is this supposed to happen?
 

Attachments

Vaeagleav

PM 2020
PM 2019
PM 2018
PM 2017
PM 2016
PM 2015
PM 2014
PM 2013
SM 2006
SM 2005
Full Member
It might depend on what version of GPS disc you have installed in the unit. I believe mine has a chime and the display changes slightly to show which lane you need to make the upcoming turn etc. I believe it also has a distance meter to show how close the turn is to you. (my spouse is the navigator and keeps eye on visuals for me). The radio sound also cuts out or dims.
May want to see if you have the latest version for your unit here:
https://here.navigation.com/north-america/
 

aveduc

Full Member
Vaeagleav said:
It might depend on what version of GPS disc you have installed in the unit. I believe mine has a chime and the display changes slightly to show which lane you need to make the upcoming turn etc. I believe it also has a distance meter to show how close the turn is to you. (my spouse is the navigator and keeps eye on visuals for me). The radio sound also cuts out or dims.
May want to see if you have the latest version for your unit here:
https://here.navigation.com/north-america/
The picture i posted is without a gps signal, once it gets a signal i choose full screen and it changes just as you described yours, but without the turn to turn voice instructions thru the bose speaker.
 

Mr.G

Full Member
aveduc said:
its all programmed and installed, i am still working on the 12volt reverse supply wire for the camera. It takes a while to get a gps signal but it eventually does work but its a pain in the ass!
Question is when i enter a destination and hit go, the voice says {please proceed to the destination bla bla} and when i have arrived to the destination the voice comes over the speakers and informs me that i have arrived, BUT it never informs me of up coming turns? is this supposed to happen?
I am new here Just bought a 2007 Avalanche only had 80,000 miles, and see you have done with your head unit that I want to do with mine, so I have 2 questions, other then the head unit, amp, and GPS antenna is there anything else I need to get, have found good deals on some units and just wondering all that i need.

and how does the XM radio work is it internal or external of the head unit, I have read that it could be either and how do I find out.

Thanks
George
 

Vaeagleav

PM 2020
PM 2019
PM 2018
PM 2017
PM 2016
PM 2015
PM 2014
PM 2013
SM 2006
SM 2005
Full Member
First welcome to the website Mr.G!

Just my .02 but instead of trying to install an old navigation unit that is kind of out of date (last mapping update discs are four years old and cost about $200.)
I would contact www.crutchfield.com and talk to one of their customer service people to get the whole list of parts you need from them. That way you aren't frankensteining a bunch of parts from various sources and if something doesn't work the different sources will blame each other or you for the problem.
 

aveduc

Full Member
Vaeagleav said:
It might depend on what version of GPS disc you have installed in the unit. I believe mine has a chime and the display changes slightly to show which lane you need to make the upcoming turn etc. I believe it also has a distance meter to show how close the turn is to you. (my spouse is the navigator and keeps eye on visuals for me). The radio sound also cuts out or dims.
May want to see if you have the latest version for your unit here:
https://here.navigation.com/north-america/
The problem with the gps signal not working was because I did not have the brown speed sensor plug at the back of the head unit fully "clicked in" :E: :E:
 

aveduc

Full Member
Mr.G said:
I am new here Just bought a 2007 Avalanche only had 80,000 miles, and see you have done with your head unit that I want to do with mine, so I have 2 questions, other then the head unit, amp, and GPS antenna is there anything else I need to get, have found good deals on some units and just wondering all that i need.

and how does the XM radio work is it internal or external of the head unit, I have read that it could be either and how do I find out.

Thanks
George
The xm is separate from your head unit, i think its behind the glove box somewhere and it will have its own antenna on the roof. I left mine plugged in.

You will need to buy a speed sensor harness.
And a back up camera if you choose to.
Re-program the head unit to your v.i.n.
A new or used UP TO DATE nav disc. Hope this helps
 

Mr.G

Full Member
Vaeagleav said:
First welcome to the website Mr.G!

Just my .02 but instead of trying to install an old navigation unit that is kind of out of date (last mapping update discs are four years old and cost about $200.)
I would contact www.crutchfield.com and talk to one of their customer service people to get the whole list of parts you need from them. That way you aren't frankensteining a bunch of parts from various sources and if something doesn't work the different sources will blame each other or you for the problem.
Hay Vaeagleav:

Thanks for the info, I hate to say it I thank I have turned in to a purest,  :B: I want to keep the stock look and am more interested in the RDS function and XM usage more then the navigation,  I have used crutchfield before and just checking them out from what I can fined only have 1Din, that is XM ready and then still have to buy the XM receiver.

Thanks again
 

pj226

New Member
I have an 07 Avalanche with the bose system, but it didn't have the nav screen.  I found a 07 Tahoe which had the nav screen, and also had the bose system.  I switched out the radio, had the dealer learn the vin to the radio. Radio works, but I have no volume control. It is full blast when ever you turn the radio on.  Dealer has no clue..  Any one here have an idea??
 

newavguy

PM 2017
PM 2015
SM 2014
PM 2013
PM 2012
SM 2011
SM 2010
SM 2009
SM 2008
SM 2007
SM 2006
Full Member
pj226 said:
I have an 07 Avalanche with the bose system, but it didn't have the nav screen.  I found a 07 Tahoe which had the nav screen, and also had the bose system.  I switched out the radio, had the dealer learn the vin to the radio. Radio works, but I have no volume control. It is full blast when ever you turn the radio on.  Dealer has no clue..  Any one here have an idea??
It would have to be the volume control on the new Nav, the Bose amp is a dump amp and does nothing but take signal in and amplify it.
 

newavguy

PM 2017
PM 2015
SM 2014
PM 2013
PM 2012
SM 2011
SM 2010
SM 2009
SM 2008
SM 2007
SM 2006
Full Member
Try a radio repair shop. If you can find one
 
Top