Please login or register.

Login with username, password and session length
Advanced search  

News:

We're changing forum software! Read the details here.

Pages: [1]   Go Down

Author Topic: 2002 avalanche randomly wont start / stay running  (Read 247 times)

0 Members and 1 Guest are viewing this topic.

AZIROC

  • Full Member
  • ***
  • Offline Offline
  • Posts: 118
2002 avalanche randomly wont start / stay running
« on: December 19, 2019, 10:15:58 AM »

Went to the gym this morning and everything was fine.  When I exited the vehicle and used my fob to lock it, and nothing.

Truck was still unlocked and when I went to start it, it cranked over and tried to start like normal, maybe ran for 1/2 sec, then died.  Tried this a few more time and same thing happened.  But then it just wouldnt start and security light was flashing. 

During this time I heard a "on/off" type clicking coming from under the dash/fuse area.  Checked fuses and nothing was bad.  By now about 5 mins passed so I tried starting it again and it fired right up.  So I drove home (4 miles) and no issues. 

I get home and same thing, turn it off and go to lock it and same thing but now ZERO power to the trucks interior.  Try to start it and same as before, ran for 1/2 sec then died.  On and off clicking was from under the panel but it seems to come from below the gauges and above the fuse panel. 

Also while doing this I moved the shifter through all the gears and in doing so, the gauges went "wild" like it was getting power then not. 

No codes and it seems when I think inhave something, it randomly "fixes" itself.  As of now I've started the thing prob a dozen times in a row, taken it around the block and parked it and it hasn't happened again. 

Edit;

So I have it down to something to do with the shifter itself.  Doesnt matter what gear I'm going to put it in, it will randomly start "freaking out" power wise  to where the gauges will fly all over the place then stop just as quick as it started. 

That all being said, after trying to get it to duplicate the issue, nothing.  Starts right up, goes through the gears fine.   Went on a few 5 mile drives,  stopped turned the truck off.  Got out like I was originally, door locked / horn honked.  Unlocked, fired right up. 
« Last Edit: December 19, 2019, 10:44:16 AM by AZIROC »
Logged
'02 Z71 Indigo Blue Metallic

Vaeagleav

  • CAFCNA 2020 Premium Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 4,887
  • The Avalanche just keeps getting better!
Re: 2002 avalanche randomly wont start running
« Reply #1 on: December 19, 2019, 10:46:24 AM »

First question.....How old is your battery? Crazy things happen sometimes with an old battery that is loosing power especially if you are having cold weather.
Second area of concern in older AVs can be the ignition/key switch going bad....several members have had weird stuff happen when switch goes bad.
Logged
2008 Z71 Silver Birch 
2004 Z71 Silver Birch before that.

AZIROC

  • Full Member
  • ***
  • Offline Offline
  • Posts: 118
Re: 2002 avalanche randomly wont start running
« Reply #2 on: December 19, 2019, 11:00:41 AM »

First question.....How old is your battery? Crazy things happen sometimes with an old battery that is loosing power especially if you are having cold weather.
Second area of concern in older AVs can be the ignition/key switch going bad....several members have had weird stuff happen when switch goes bad.

Battery is about a year old.  (Nov 18).

I had a buddy come over who's a mechanic and he was thinking the same area (ignition switch or shifter mechanism) but everything was getting correct voltage.  We did the whole "wiggle test" and nothing was loose.  Infact, if anything that "fixed' the issue to now instead of happening every time, its damn near impossible to recreate. 

And of course the same issue where when I try to lock my truck with the fob, it wont do it all the time. No noise or anything like it's even trying.  But if I get in the truck,  cycle the key, it will lock/unlock with the fob. 
Logged
'02 Z71 Indigo Blue Metallic

AZIROC

  • Full Member
  • ***
  • Offline Offline
  • Posts: 118
Re: 2002 avalanche randomly wont start / stay running
« Reply #3 on: December 19, 2019, 13:20:51 PM »

Had to go to work but same thing happened when leaving.  Fob didnt do poop. Unlocked the door manually. Tried to start the truck and it started/died in 1/2 sec.  Moved the shifter from Park to 1st back to park, fired right up.
Logged
'02 Z71 Indigo Blue Metallic

EXT4ME

  • CAFCNA 2020 Premium Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 3,526
  • If one is good, then two must be better. Right?
Re: 2002 avalanche randomly wont start / stay running
« Reply #4 on: December 19, 2019, 13:37:36 PM »

Perhaps it would be a good idea to locate and check the major grounds.

There are several on these trucks.
Logged
2004 Cadillac Escalade EXT, White Diamond, New Shale front seat leather from The Seat Shop. WeatherTech FloorLiner DigitalFit. Powerflow Pro-Fit Splash Guards. Carpet matched 60/40 Mid-Deck Mod. Arnott/Bilstein front shocks and rear air shocks with Arnott air compressor kit. Continental Gatorback belts.  BFGoodrich Advantage T/A Sport LT.
2003 Chevrolet Avalanche Z-66 1500, Victory Red, Dark Charcoal leather, cladded. Carpet matched 60/40 Mid-Deck Mod. Firestone Destination A/T ROWL.

AZIROC

  • Full Member
  • ***
  • Offline Offline
  • Posts: 118
Re: 2002 avalanche randomly wont start / stay running
« Reply #5 on: December 19, 2019, 14:36:22 PM »

You know where they are by chance? Or a link?
Logged
'02 Z71 Indigo Blue Metallic

BainMan

  • Full Member
  • ***
  • Offline Offline
  • Posts: 276
  • Send it!
Logged
2010 LTZ 4x4

AZIROC

  • Full Member
  • ***
  • Offline Offline
  • Posts: 118
Re: 2002 avalanche randomly wont start / stay running
« Reply #7 on: December 19, 2019, 15:04:47 PM »

Awesome.  Thanks. 

So far it seems like everything I find points to the passkey or bcm.... but the confusing part is why shifting from Park to 1st then back "fixes" the issue. 
Logged
'02 Z71 Indigo Blue Metallic

AZIROC

  • Full Member
  • ***
  • Offline Offline
  • Posts: 118
Re: 2002 avalanche randomly wont start / stay running
« Reply #8 on: December 20, 2019, 01:24:45 AM »

I left work to home and same thing.  Fob didnt do anything so I unlocked manually.  Opened the door and zero power to anything (including interior lights) .  Put the key in the ignition and turn to the on position. Interior lights come on, dash, radio (reset to 1200) everything has power.  Try to start it and it starts then dies.  Go from park to 1st to park (pretty quickly), try and start the truck and it fires right up.

When I got home I took the battery connections off.  Partially to check the connection and partially to see if I just drain the whole system it fixes itself with  relearning.  While doing so and taking off the positive terminal, it has alittle corrosion.  So I'll clean it and the battery up in the morning and try again.  I also will have to see that's "wet" around it.  Possibly could be a leaking battery as again, its Phoenix and we dont have weather unless it's hot and not so hot *crossing my fingers. 

Logged
'02 Z71 Indigo Blue Metallic

AZIROC

  • Full Member
  • ***
  • Offline Offline
  • Posts: 118
Re: 2002 avalanche randomly wont start / stay running
« Reply #9 on: December 20, 2019, 09:00:00 AM »

This morning I woke up alittle early. mostly to get to costco to see about returning the battery under warranty but also to clean the connections.  I did take the cover off and yeah, that corrosion was pretty bad.  a steel brush knocked the loose stuff off, but i had to get a small flathead to scrape a good chunk off  the battery side wasnt anywhere near a bad thankfully.  wire brush and 5 secs cleaned it right up. 

connected the battery cables and it fired right up.  so now ill "test" it and let it sit for about 15 mins while i wait for costco to open and see if it does it again. 
Logged
'02 Z71 Indigo Blue Metallic
Pages: [1]   Go Up
 

Page created in 0.101 seconds with 25 queries.