• If you currently own, previously owned or want to own an Avalanche, we welcome you to become a member today. Membership is FREE, register now!

Help, seats won’t adjust vertically!

Aerohokie

SM 2020
PM 2017
Full Member
Joined
Apr 16, 2006
Messages
248
Location
Pensacola, FL
I removed my seats from my 2004 Z71 and put on new seat covers as well as a new foam cushion for the driver bottom. Both seats are installed and everything works except for the vertical adjustment.

This is the recline button. Recline works, just not up and down. Both the passenger and driver seat are doing it. I got a new switch for $20, but no change, so not the switch.

Does anyone know why this would be happening, especially to driver and passenger? All connections are good, the 8 way seats are working 6 ways!
 

Aerohokie

SM 2020
PM 2017
Full Member
Joined
Apr 16, 2006
Messages
248
Location
Pensacola, FL
Ok, I did more troubleshooting, I think I was wrong about the back adjustment sliding. There’s 3 motors. Recline motor works, then There are 2 big motors next to each other with screw shafts, one connected to rear and the other to the front. The front motor doesn’t move but it does make a sound. I disconnected the shaft and manually lowered the seat. it sounds like the gears between the motor and shaft are broke because sometimes it moves, sometimes it doesn’t.

The black plastic yoke doesn’t screw or unscrew freely on the shaft. On the plus side, if I leave it disconnected, I fit in the seat better. Any ideas on how to fix this? Junkyard grab a motor and yoke assembly?
 
Top