Please login or register.

Login with username, password and session length
Advanced search  

News:

Keep CAFCNA Alive! Become a Supporting Member Today!

Pages: [1]   Go Down

Author Topic: Loss of Power, Check Engine, Traction Control, Anti-skid  (Read 112 times)

0 Members and 1 Guest are viewing this topic.

Hound

  • CAFCNA 2006 Supporting Member
  • Full Member
  • *
  • *
  • Offline Offline
  • Posts: 686
Loss of Power, Check Engine, Traction Control, Anti-skid
« on: November 30, 2019, 15:16:46 PM »

 :help:  2013

Truck was operating normally.  Stopped at a red light.  Went to accelerate on green and nothing happened.  "Loss of Power" or "Reduced Power" was on the DIC, along with the check engine light.  Shut the motor off and restarted.  Now, stabilitrac and anti-skid lights are on as well as check engine.  Very rough idle.  No throttle/Loss of power. 

Limped it 5 miles home. 

First thought was fuel pump because I think this happened 6 years ago....can't recall.  Tried to do some research here and saw a suggestion for traction control sensor.

Absent reading codes, any ideas?
Logged
Hound
2013 LT, Silver Ice All-Star Pkg, Chrome tow hooks, Grover Emergency airhorn, iSimple A2DP Streaming Audio

Former:  '04 Z66 WBH, Dk Metallic Blue, 20" Evo Velociti 6, Grover airhorns, Maglite, dual stainless tip, CarriageWorks billet grill, tilting headrests, Snakeeyes backup cam.

ygmn

  • Administrator
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 33,797
  • Insert Funny Text Here _______________ .
Re: Loss of Power, Check Engine, Traction Control, Anti-skid
« Reply #1 on: November 30, 2019, 15:33:35 PM »

No way without codes.... unless it has no codes then it would be fuel pump... but then it just dies and does not run... no real lights
Logged
Thread Killer ... After I post they die?
2002 Pewter Z66 - Sept 2001
CAFCNA Album
LSU BABY!
YANKEES BABY!
SAINTS BABY!

Hound

  • CAFCNA 2006 Supporting Member
  • Full Member
  • *
  • *
  • Offline Offline
  • Posts: 686
Re: Loss of Power, Check Engine, Traction Control, Anti-skid
« Reply #2 on: December 1, 2019, 11:29:00 AM »

No way without codes....

This morning, truck running normally but engine light  is on.  Took it over to Advance Auto and they read the codes.  Told me it was the Throttle Position Sensor.  Curious why it would run like crap last night, even after a restart, but then be fine this morning. 
Logged
Hound
2013 LT, Silver Ice All-Star Pkg, Chrome tow hooks, Grover Emergency airhorn, iSimple A2DP Streaming Audio

Former:  '04 Z66 WBH, Dk Metallic Blue, 20" Evo Velociti 6, Grover airhorns, Maglite, dual stainless tip, CarriageWorks billet grill, tilting headrests, Snakeeyes backup cam.

ygmn

  • Administrator
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 33,797
  • Insert Funny Text Here _______________ .
Re: Loss of Power, Check Engine, Traction Control, Anti-skid
« Reply #3 on: December 1, 2019, 11:45:33 AM »

Did they give you PXXX code?

Could be connector at TPS spray with WD40 and reconnect solidly.
Reset Codes and drive some more.

Happened to me after 3 months of owning mine in 2001. Dealer cleaned and reset and no issues ever since.
Logged
Thread Killer ... After I post they die?
2002 Pewter Z66 - Sept 2001
CAFCNA Album
LSU BABY!
YANKEES BABY!
SAINTS BABY!

ca2kjet

  • WebMaster
  • Full Member
  • *
  • *
  • *
  • Offline Offline
  • Posts: 789
  • something secret steers us
Re: Loss of Power, Check Engine, Traction Control, Anti-skid
« Reply #4 on: December 1, 2019, 12:49:02 PM »

Have the spark plugs been replaced?
Logged

Black on Black - 2007 Avalanche 4x4 LT3 Z71

EXT4ME

  • CAFCNA 2019 Premium Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Online Online
  • Posts: 3,311
  • ... I saw a DEADHEAD sticker on a Cadillac ...
Re: Loss of Power, Check Engine, Traction Control, Anti-skid
« Reply #5 on: December 1, 2019, 14:55:59 PM »

This morning, truck running normally but engine light  is on.  Took it over to Advance Auto and they read the codes.  Told me it was the Throttle Position Sensor.  Curious why it would run like crap last night, even after a restart, but then be fine this morning.

Mine has done this three or four times over the past three or four years.

Each time I cleaned and re-seated the TB connector and it would go a long time before it did it again.

The last two times were in the past three months.

I replaced the throttle body today because the codes always pointed to the TB throttle position sensor.

I figured 234K miles was good enough.
Logged
2004 Cadillac Escalade EXT, White Diamond, New Shale front seat leather from The Seat Shop. WeatherTech FloorLiner DigitalFit. Powerflow Pro-Fit Splash Guards. Arnott/Bilstein front shocks and rear air shocks with Arnott air compressor kit. Refinish Restorer. SeaFoam. Goodyear (Now Continental) Gatorback belts.  BFGoodrich Advantage T/A Sport LT.

Hound

  • CAFCNA 2006 Supporting Member
  • Full Member
  • *
  • *
  • Offline Offline
  • Posts: 686
Re: Loss of Power, Check Engine, Traction Control, Anti-skid
« Reply #6 on: December 1, 2019, 17:24:15 PM »

Have the spark plugs been replaced?

Not recently.  But I am going to pull the TB connector and clean it up a bit
Logged
Hound
2013 LT, Silver Ice All-Star Pkg, Chrome tow hooks, Grover Emergency airhorn, iSimple A2DP Streaming Audio

Former:  '04 Z66 WBH, Dk Metallic Blue, 20" Evo Velociti 6, Grover airhorns, Maglite, dual stainless tip, CarriageWorks billet grill, tilting headrests, Snakeeyes backup cam.
Pages: [1]   Go Up
 

Page created in 0.097 seconds with 25 queries.