Please login or register.

Login with username, password and session length
Advanced search  

News:

We're changing forum software! Read the details here.

Pages: [1]   Go Down

Author Topic: Hard Start when warm  (Read 845 times)

0 Members and 1 Guest are viewing this topic.

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Hard Start when warm
« on: December 3, 2019, 13:24:31 PM »

Hey y'all,

Long time reader, first time posting a question though. I'm getting SUPER frustrated with an issue with my 2008 LTZ with 337,000km. Several months ago, I had an initial code thrown where it was indicating that my rear O2 sensors were failing (don't remember the code off-hand). So I took it to my mechanic, who has been really good to date. They check it out and tell me they're bad and that my cats are also running way hotter than they should. He also suggests replacing the front O2 sensors as well, since they don't appear to have been replaced before (at least not since I owned the truck). So we replace the four O2 sensors, spark plugs all around (they were due to be replaced) and the two catalytic converters...a few days later, check engine light comes back but this time it's throwing a P1133 and P1153 for the front O2 sensors. They do a leak test on the exhaust and nothing found, checked the intake and no leaks, Mass Airflow sensor tests okay. Clear the codes and lets me drive it for a few days to see what happens. I drove it for a few weeks and the code comes and goes, with no rhyme or reason. I look at my cheapy scan tool and it keeps getting triggered by what it lists as TID$80 and $81 Switches Units; the min is 76 and it's going down to 65 at times, throwing the code. So I give my mechanic the info and they scan it on their tool and they can see that as well, but when they check it, it's over the minimum. Take it back home and drive it with the CEL coming on and off every few days. Then a month later, my oil pressure sensor went out and take it to my mechanic. While doing the sensor, they're going to do the intake manifold gasket and are optimistic that will fix it as they had another GM that had the same codes and replaced the intake manifold gasket and fixed it. No such luck in my case as the code is back after it went through a relearn process (their words). Back to the garage and they went through everything again, they changed the spark plugs again, saying that they seemed to be fuel fouled, but that didn't change anything.

Now here's where things get even more frustrating...they check the fuel injectors and they tell me that all the injectors are streaming out fuel instead of it being a mist and they're certain that's going to fix the two O2 codes coming up. So I tell them to change the injectors and now not only do the codes not go away, it now takes several seconds for the truck to start...but not first thing in the morning. It starts without issue first thing but if I shut it off and start it 10-15 minutes later, it cranks for several seconds before it start up and sometimes, I'll have to try it a second time before it starts. Since they did that, I ended up replacing the Mass Airflow sensor and that seems to have made the P1133 code disappear. Yesterday, they sent my truck to have the PCM reprogrammed as they found a TSB for that problem. So far, I don't have the P1153 code come up but the hard starting issue continues. I know he's going to say that the fuel pump needs to be replaced next, but it NEVER started like that until they changed the injectors and I tend to think that there's a faulty injector that's dumping fuel when it shuts down. Any suggestions would be GREATLY appreciated before going a fuel pump route.

I should mention that with my scan tool, the fuel pressure with the key on shows around 58-60psi and then when started it stays there for a bit before dropping to 43psi on average.
Logged

ygmn

  • Administrator
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 33,977
  • Insert Funny Text Here _______________ .
Re: Hard Start when warm
« Reply #1 on: December 3, 2019, 13:38:27 PM »

Did they check if thenew O2 sensors are any good?
Logged
Thread Killer ... After I post they die?
2002 Pewter Z66 - Sept 2001
CAFCNA Album
LSU BABY!
YANKEES BABY!
SAINTS BABY!

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Re: Hard Start when warm
« Reply #2 on: December 3, 2019, 13:47:33 PM »

Oh yeah, forgot to mention that the front O2 sensors were replaced a second time (under warranty). Both times, they were ACDelco sensors.
Logged

redheadedrod

  • CAFCNA 2017 Supporting Member
  • Full Member
  • *
  • *
  • Offline Offline
  • Posts: 2,942
  • 2003 Z71
Re: Hard Start when warm
« Reply #3 on: December 3, 2019, 18:15:51 PM »

Generally the rear O2 sensors are just the cats... They should have just changed the cats originally and stopped there.

Have you changed the spark plugs and wires yet? Those generally can last 100k miles but can show measurable degration after 50-60k miles.

Rodney
Logged
2003 Cladded Black Z71 - PC installed otherwise mostly stock.
4 Light Brake/Turnsignal
All on high and FTDRL (BCM friendly version)

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Re: Hard Start when warm
« Reply #4 on: December 4, 2019, 07:14:41 AM »

Yeah, the wires were changed about 6 months ago and the plugs have now been changed twice in the last 6 months (last time was 2 weeks ago).
Logged

EXT4ME

  • CAFCNA 2020 Premium Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Online Online
  • Posts: 3,606
  • If one is good, then two must be better. Right?
Re: Hard Start when warm
« Reply #5 on: December 4, 2019, 08:22:16 AM »

I read your fuel pressure readings.

How quickly does the fuel pressure leak down with the key off?

Perhaps check the fuel pressure with a manual gauge.
« Last Edit: December 4, 2019, 08:24:59 AM by EXT4ME »
Logged
2004 Cadillac Escalade EXT, White Diamond, New Shale front seat leather from The Seat Shop. WeatherTech FloorLiner DigitalFit. Powerflow Pro-Fit Splash Guards. Carpet matched 60/40 Mid-Deck Mod. Arnott/Bilstein front shocks and rear air shocks with Arnott air compressor kit. BFGoodrich Advantage T/A Sport LT.
2003 Chevrolet Avalanche Z-66 1500, Victory Red, Dark Charcoal leather, cladded. WeatherTech FloorLiner DigitalFit. Carpet matched 60/40 Mid-Deck Mod. Firestone Destination A/T ROWL.

ygmn

  • Administrator
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 33,977
  • Insert Funny Text Here _______________ .
Re: Hard Start when warm
« Reply #6 on: December 4, 2019, 08:54:07 AM »

What are the codes stored in the engine computer?

See these sites and enter the codes for good help with issue.
Entering all the codes on some bring up specific issues like yours maybe:

https://www.obd-codes.com/
http://www.obdii.com/
https://www.engine-codes.com/
https://troubleshootmyvehicle.com/
https://www.aa1car.com/
Logged
Thread Killer ... After I post they die?
2002 Pewter Z66 - Sept 2001
CAFCNA Album
LSU BABY!
YANKEES BABY!
SAINTS BABY!

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Re: Hard Start when warm
« Reply #7 on: December 6, 2019, 09:37:05 AM »

Looks like the dealer's reprogram got rid of the P1153 code; no check engine light since it was done on Monday. I don't have a manual fuel pressure gauge, but my scan tool shows the pressure at about 5 PSI before I turn the key to the ON position (it seems to be able to read it if I turn the key to the first position) and 60 PSI when I turn the key to the ON position. The hard start is still happening if I restart the truck after 10 minutes and as late as 5 hours later. It starts normally when I first start it in the morning or it's been sitting for several hours. When the truck does finally start, you can definitely smell raw fuel from the exhaust. I suspect that it's one of the fuel injectors staying open after it's shut down and dumping fuel in the cylinder (thus losing pressure).
Logged

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Re: Hard Start when warm
« Reply #8 on: December 12, 2019, 08:14:01 AM »

Still trying to figure out the hard start...last thing they did was pull the fuel rail off and checked the injectors again. No leaking from any of the injectors, so I guess that's good news. He's still baffled as to why it would start without issue when the engine is cold but hard start after sitting for 15 minutes. I have noticed this week, now that we're in a bit of a cold spell around -10F, that the that hard starting happens is less than before. What I mean is that after the initial start in the morning (which starts normally), it would hard start up to 4-6 hours in. I'm now finding with the cold temperatures outside, that's being cut down to 3-4 hours.
Logged

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Re: Hard Start when warm
« Reply #9 on: January 13, 2020, 12:38:21 PM »

Still trying to figure out my issue, which is still happening. Starts normally when I start it first thing in the morning but when the truck sits for 15 minutes and longer, it hard starts. There are no codes when scanned. The truck sat unused for several days when I was out of town and it started no problem. When it hard starts I can see some black smoke and there's a definite gas smell. Any help where I should look next would be greatly appreciated. 
Logged

BainMan

  • Full Member
  • ***
  • Offline Offline
  • Posts: 296
  • Send it!
Re: Hard Start when warm
« Reply #10 on: January 13, 2020, 12:56:15 PM »

Does your fuel pump prime up on warm starts?

What is the fuel pressure:
1. idle engine running
2. key off
3. 5 minutes after shutdown
4. 10 minutes after shutdown

 
« Last Edit: January 13, 2020, 12:59:56 PM by BainMan »
Logged
2010 LTZ 4x4

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Re: Hard Start when warm
« Reply #11 on: January 13, 2020, 13:33:55 PM »

Does your fuel pump prime up on warm starts?  - Yes it does

What is the fuel pressure: Unfortunately I don't have a mechanical fuel pressure gauge, however with the scan tool I have, I can read the fuel pressure when on and about 5 minutes off.
1. idle engine running - starts at 58-60 psi and after it has warmed up will drop to 43 psi and stays there
2. key off - rises up to around 50 psi when I shut off the truck
3. 5 minutes after shutdown - around 50 psi
4. 10 minutes after shutdown - my scan tool will shut off after 5 mins
Logged

BainMan

  • Full Member
  • ***
  • Offline Offline
  • Posts: 296
  • Send it!
Re: Hard Start when warm
« Reply #12 on: January 14, 2020, 07:03:06 AM »

Can you rent/borrow/buy a mechanical fuel gauge? I suspect the fuel pump like you do, but would prefer to diagnose further before biting that bullet.
MAF and throttle body clean?
« Last Edit: January 14, 2020, 07:06:30 AM by BainMan »
Logged
2010 LTZ 4x4

ygmn

  • Administrator
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 33,977
  • Insert Funny Text Here _______________ .
Re: Hard Start when warm
« Reply #13 on: January 14, 2020, 10:21:12 AM »

Egads a lot of stuff was done and it seems worse since you threw original o2 code.

do mechanical fuel pressure test at the rail.

Double check the injectors were replaced with proper ones from GM.

Logged
Thread Killer ... After I post they die?
2002 Pewter Z66 - Sept 2001
CAFCNA Album
LSU BABY!
YANKEES BABY!
SAINTS BABY!

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Re: Hard Start when warm
« Reply #14 on: January 17, 2020, 09:17:53 AM »

Can you rent/borrow/buy a mechanical fuel gauge? I suspect the fuel pump like you do, but would prefer to diagnose further before biting that bullet.
MAF and throttle body clean?

Yeah I'm going to go to the local parts store and rent a mechanical fuel gauge and get some more concrete results. The MAF was replaced last month and they cleaned the throttle body when they did the intake manifold gasket.
Logged

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Re: Hard Start when warm
« Reply #15 on: February 15, 2020, 13:34:33 PM »

So I was finally able to get my hands on a mechanical fuel pump gauge and here's my findings...

With the key on: 56 PSI
When running at idle: 44 PSI
5 minutes after shutdown: 68 PSI
10 minutes after shutdown: 74 PSI
20 minutes after shutdown: 14 PSI

It's at that point where it hard starts. When I turn the key back on, it goes to 56 PSI but will take several seconds to start.

At WOT, the pressure goes up about 4 PSI then once I let off the throttle, it momentarily drops to about 42 PSI then back to 44 PSI at idle.
Logged

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Re: Hard Start when warm
« Reply #16 on: February 20, 2020, 14:24:40 PM »

Wondering if anyone had any ideas as to why the pressure seems to be going up after shutdown? I still think the injectors are releasing the pressure after 10 minutes.
Logged

BainMan

  • Full Member
  • ***
  • Offline Offline
  • Posts: 296
  • Send it!
Re: Hard Start when warm
« Reply #17 on: February 20, 2020, 14:51:05 PM »

The fuel pressure rise does not seem normal, a few PSI sure from heat soak but going from 44 to 74 with engine off seems very wrong to me... I'm not educated enough to know what PSI rise is normal, but it just can't be 30psi.  Do you hear the pump run during this time?

The bleed off can be narrowed down by pinching off the rubber fuel line nearest the engine. They make fuel line pliers specifically for this but there are many ways if you are creative, just don't damage the line. If the pressure bleed off continues, it's on the motor side of your pinched off line. If the bleed off stops, the leak down is coming from the tank side of the pinch.
Logged
2010 LTZ 4x4

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Re: Hard Start when warm
« Reply #18 on: February 25, 2020, 06:41:16 AM »

I agree that it seems excessive when the engine is shut off; the fuel pump is definitely not running when the key is turned off. I couldn't see a rubber fuel line on my Av, it's a metal line going into the fuel rail. When it hard starts, there's always a little bit of black smoke and if I don't put the gas pedal to the floor, it'll take a few times before it starts.
Logged

EXT4ME

  • CAFCNA 2020 Premium Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Online Online
  • Posts: 3,606
  • If one is good, then two must be better. Right?
Re: Hard Start when warm
« Reply #19 on: February 25, 2020, 07:42:37 AM »

A leaking fuel injector would help in creating a fuel washed cylinder after engine shut down and would result in hard starting and black smoke.

That abnormally high fuel pressure after shut down is a strange one, however.
Logged
2004 Cadillac Escalade EXT, White Diamond, New Shale front seat leather from The Seat Shop. WeatherTech FloorLiner DigitalFit. Powerflow Pro-Fit Splash Guards. Carpet matched 60/40 Mid-Deck Mod. Arnott/Bilstein front shocks and rear air shocks with Arnott air compressor kit. BFGoodrich Advantage T/A Sport LT.
2003 Chevrolet Avalanche Z-66 1500, Victory Red, Dark Charcoal leather, cladded. WeatherTech FloorLiner DigitalFit. Carpet matched 60/40 Mid-Deck Mod. Firestone Destination A/T ROWL.

BainMan

  • Full Member
  • ***
  • Offline Offline
  • Posts: 296
  • Send it!
Re: Hard Start when warm
« Reply #20 on: February 25, 2020, 07:58:28 AM »

I couldn't see a rubber fuel line on my Av,
If you keep following it towards the rear (possibly behind the motor) it has to change from hard/fixed line to some kind of flexible hose to accommodate movement. I'm not sure if that's rubber or braided or what on our trucks. If you keep following the line back and down (you may need to be under the vehicle) can you find where it shifts from hard line to something else? Maybe just after the fuel tank is an option too?

I'm just hoping to narrow down your issue a bit.. Like EXT said the the black smoke can indicate leaky injectors, but the pressure issues point towards regulator/pump, i guess both could be an issue. What are you planning as a next step?
« Last Edit: February 25, 2020, 08:07:43 AM by BainMan »
Logged
2010 LTZ 4x4

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Re: Hard Start when warm
« Reply #21 on: February 25, 2020, 09:28:02 AM »

My assumption is that the pressure is releasing through one or more of the fuel injectors but no idea why it's building up so high after shutting down. The real frustrating thing is that it always started without issue before they changed out the injectors.
Logged

DanoWpg

  • Member
  • **
  • Offline Offline
  • Posts: 14
  • I love the Chevy Avalanche
Re: Hard Start when warm
« Reply #22 on: Yesterday at 14:04 »

Well after they convinced me that the fuel pump HAD to be the culprit, I had them replace it and wouldn't you know it, it STILL hard starts. I don't think there's anything left to change at this point in the fuel system. If there's any solace, the hard start doesn't seem happen as often or for as long as before. If anyone has any ideas, I'm open to them.
Logged

ygmn

  • Administrator
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 33,977
  • Insert Funny Text Here _______________ .
Re: Hard Start when warm
« Reply #23 on: Today at 04:33 »

Did anyone do proper Fuel pressure test??
With mechanical gage at fuel rail?

Put gage on...
Turn key on
start engine...
then turn off engine?
Does it bleed off? if so how long does it take?

Record pressures at each step

I wonder if you have a bad new injector??
BAd spark plug wire.... also show up when hot as will bad plug
Logged
Thread Killer ... After I post they die?
2002 Pewter Z66 - Sept 2001
CAFCNA Album
LSU BABY!
YANKEES BABY!
SAINTS BABY!

ronthehandymanga

  • CAFCNA 2018 Premium Member
  • Full Member
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • *
  • Offline Offline
  • Posts: 1,450
Re: Hard Start when warm
« Reply #24 on: Today at 04:48 »

See post 15.

Did anyone do proper Fuel pressure test??
With mechanical gage at fuel rail?

Put gage on...
Turn key on
start engine...
then turn off engine?
Does it bleed off? if so how long does it take?

Record pressures at each step

I wonder if you have a bad new injector??
BAd spark plug wire.... also show up when hot as will bad plug
Logged
02 Indigo blue Avalanche K2500
03 K2500 LT Suburban, work truck
69 CST 396 Fleetside long PU
68 Chevelle SS 396
Pages: [1]   Go Up
 

Page created in 0.155 seconds with 25 queries.