301, Stabilitrak, traction control and a fouled Sprak Plug 2013 LTZ Avalanche

badaz06

New Member
Ugh.

A few months ago I started throwing a 301 code, cylinder misfire.  I bought a new set of coil packs, plugs, wires, and installed them and everything seemed fine.  A few days ago the issue popped up again, but this time with the Stabilitrak and Traction Control lights.  Engine runs rough esp at idle, definitely a loss of power.  The codes for stabilitrak and traction control are on, then off, then a few miles later on again...Chevy cant find out why.

So I take into the dealership again when the lights come on and stay on.  The said the cyl plug is fouled, so I'm assuming there's blowback.  Now the question.

The truck has about 88K miles on it.  Chevy says I should either tear the engine down and see what's what (~$1200) or just swap with a new 5.3.  No idea on that cost to get that installed.

I'm a bit hesitant to drop another 5.3 in...seems you can google 301 codes and there are a ton of the 5.3's with this issue, though the tech I spoke to said with this particular late model he was surprised to see it even though it was common on earlier models.  So, my options are:

Spend 1200 and tear it down
drop another 5.3 in it with warranty for 3 years 100K miles
drop another motor like a 6L in it, which of course the dealership wont do.  I could be wrong but the 6L should marry up fine without me having to install a new tranny, but if I'm wrong feel free to call that out.
Buy a new Truck

Argh.

Thank you.
 

ygmn

Staff member
Administrator
Moderator
Charter Member
PM 2020
PM 2019
PM 2018
PM 2017
PM 2016
PM 2015
PM 2014
PM 2013
PM 2012
SM 2011
SM 2010
SM 2009
SM 2008
SM 2007
SM 2006
SM 2005
SM 2004
SM 2003
Full Member
get second opinion.

Could be the AFM and lifters.
intake air leak..
fuel injector, plug, wire, coil etc etc etc.
Fuel pump

So many things can cause a misfire..

Find a good shop that can diagnose and not just replace parts....

is is for one particular cylinder or the RANDOM?

What codes today?

PXXXX????
 

badaz06

New Member
P301 was the last core I saw (cyl 1 misfire).  Going to take it somewhere else and do a leak test  That?s been consistent.
 

ygmn

Staff member
Administrator
Moderator
Charter Member
PM 2020
PM 2019
PM 2018
PM 2017
PM 2016
PM 2015
PM 2014
PM 2013
PM 2012
SM 2011
SM 2010
SM 2009
SM 2008
SM 2007
SM 2006
SM 2005
SM 2004
SM 2003
Full Member
Well if cyl 1 only then you need to check stuff on cylinder 1.
Like swap wire from 1 to 3.
Swap coil from 1 to 5.
swap injector 1 to 7.
Swap plug 1 to 4

Or something similar...

And see if problem moves.
If it moves you can see what is wrong by where it went.

 
Top